Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: [1]   Go Down

Author Topic: Car playing up again. Camshaft and other crazy code driving me crazy.  (Read 131 times)

0 Members and 1 Guest are viewing this topic.

addy

  • Junior Member
  • **
  • Online Online
  • Gender: Male
  • paisley. Scotland  UK
  • Posts: 185
    • 1995 2.0ltr cd estate.
    • View Profile

Took car out today. It drove great parked up at my mums for a while.When I went to start it, the engine light came on (not spanner one), and it ran as if missfiring. Got it home, checked codes P0340 Camshaft Position Sensor Circuit No Signal, and P1700 SVS request via CAN. So I cleared them and tried starting the car, the engine light came on again with same codes. Cleared them again and let it run for a while, then it felt lumpy as if missfiring, checked the codes and got a new one, P0351 - Ignition Coil 1 Incorrect Signal. I have changed both Cam and Cranksensor with Genuine Vauxhall ones (From local Dealer) not so long ago. Also was getting missfire on Cylinder 1 error code, after I had done both sensors, so changed Coilpack and new plugs.  Does anyone know what could be causing these to appear again? When I was doing Camsensor I checked all the timing marks and they all lined up. Removed the MAF connector and the car dropped a few revs.

Thanks in advance. If I cann't sort it then going to big carpark in the sky and I will get a V6. Are the new V6 DBW and how reliable are they?
Logged
Drives 1995 2.0ltr CD Estate.  2001 2.2 CDX Estate

Bigron

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Witham, Essex
  • Posts: 3289
    • Omega 2.6 V6 Auto '51 Reg
    • View Profile

Serek is a bit far from you, in Huntingdon, but you could always phone him with your problem?

Ron.
Logged

addy

  • Junior Member
  • **
  • Online Online
  • Gender: Male
  • paisley. Scotland  UK
  • Posts: 185
    • 1995 2.0ltr cd estate.
    • View Profile

Thanks for the quick reply. I didn't think a engine could cause so much aggro.
Logged
Drives 1995 2.0ltr CD Estate.  2001 2.2 CDX Estate

Bigron

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Witham, Essex
  • Posts: 3289
    • Omega 2.6 V6 Auto '51 Reg
    • View Profile

You're welcome, just don't break it until you have spoken to the Omega miracle-worker, Serek!
Ahem, other miracle-workers are available.....  :y 8)

Ron.
Logged

addy

  • Junior Member
  • **
  • Online Online
  • Gender: Male
  • paisley. Scotland  UK
  • Posts: 185
    • 1995 2.0ltr cd estate.
    • View Profile

Thanks for suggestion. The annoying thing is that it has just passed MOT. Body work is in good condition, no banging or strange noises. Drives great when working.  Just used to the old 2.5 Omegas, never had any trouble with them. Even the wifes 1995 2.0 Omega is better behaved. ;D

If it costs silly money to sort, will look at a V6 seen a nice 02 for sale, good price and MOT History looks OK.
Logged
Drives 1995 2.0ltr CD Estate.  2001 2.2 CDX Estate
Pages: [1]   Go Up
 

Page created in 0.072 seconds with 17 queries.