Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to OOF

Pages: [1]   Go Down

Author Topic: Vauxhall omega stereo started making popping noise.  (Read 288 times)

0 Members and 1 Guest are viewing this topic.

bobbyduke

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • norfolk
  • Posts: 5
    • omega 3.2 elite
    • View Profile
Vauxhall omega stereo started making popping noise.
« on: 26 April 2017, 10:53:45 »

Vauxhall omega 3.2 elite model with Siemens NCDC 2013 stereo fitted, i have just started to get a thumping noise when car stereo is on, front right large speaker is worse but does it all round on and off. When i first turn the ignition on is does it with stereo off, but if i turn the stereo on then off the thumping stops. Any ideas guys please?
Logged

phipps877

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Bedfordshire
  • Posts: 30
    • Omega 2.6 CDX
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #1 on: 26 April 2017, 12:01:47 »

Is it louder in the right speaker because you are closer to it? I would check the ground to the amp or check for a voltage drop in reference to the battery voltage. There are other things you could try but I don't want to get to technical on you. You should not be able to get any reaction from the amp without the head unit switched on. If it is really louder on the front right speaker check for a short to ground or a supply on that speaker wire with the head unit turned off.
Logged

bobbyduke

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • norfolk
  • Posts: 5
    • omega 3.2 elite
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #2 on: 26 April 2017, 13:03:50 »

Thanks for the reply, the front right pops pretty loud where the rest gives a small popping noise off compared to that one speaker, radio plays for few seconds then pop and nothing from the radio then 5 seconds later comes back on etc. Just strange it does it when I first start the car up with radio set to off, then if I turn it on then off I get no popping noises from them. Will also mention the lcd display is hit and miss goes on and off with lines etc and if I hit around the dash it comes on fine for a while then plays up again when going over bumps, also part of the dash light can be dim a tap on the screen gets this working again, the car has always had that problem since I have had it though, just wondered if this could be connected to it all.

Another thing sometimes alarm goes off when I start the motor which goes off if I take the car out and start again.
Logged

phipps877

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Bedfordshire
  • Posts: 30
    • Omega 2.6 CDX
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #3 on: 26 April 2017, 17:31:38 »

If I was you I would remove the stereo (make sure you have the code) and check the cage still has the bolt at the back and the leads are properly seated in the cage. Then do the checks I said around the front right speaker.
Logged

Lizzie Zoom

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Female
  • Kent
  • Posts: 1634
    • Omega 3.2 V6 ELITE 2003
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #4 on: 26 April 2017, 17:39:55 »

Thanks for the reply, the front right pops pretty loud where the rest gives a small popping noise off compared to that one speaker, radio plays for few seconds then pop and nothing from the radio then 5 seconds later comes back on etc. Just strange it does it when I first start the car up with radio set to off, then if I turn it on then off I get no popping noises from them. Will also mention the lcd display is hit and miss goes on and off with lines etc and if I hit around the dash it comes on fine for a while then plays up again when going over bumps, also part of the dash light can be dim a tap on the screen gets this working again, the car has always had that problem since I have had it though, just wondered if this could be connected to it all.

Another thing sometimes alarm goes off when I start the motor which goes off if I take the car out and start again.

Cannot help much on the radio front, but can only say it sounds like a short / loose wire somewhere.

As for the alarm, mine can go off when I first start the car.  But I have found it is when I  put the key in and turn it right around straightaway to fire the engine.  If you just turn the key to the point the warning lights come on the dashboard, then turn it to start the engine all is ok; the alarm will not sound.  Peculiar yes, but that is what I have found on my 3.2.  Just a co-incidence, or something that just happens on our late 3.2's? ;)
« Last Edit: 26 April 2017, 17:44:54 by Lizzie Zoom »
Logged

Lizzie Zoom

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Female
  • Kent
  • Posts: 1634
    • Omega 3.2 V6 ELITE 2003
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #5 on: 26 April 2017, 17:48:37 »

................and before someone asks, when I first noted this alarm "fault"  I first changed the power sounder, twice, even returning the first because the alarm still went off when starting as I thought Vx had sold me a faulty one!

Then I had a Vauxhall technician carryout tests on my alarm system.............at a cost of 75..........and he found no fault. ::) ::) ;)
Logged

bobbyduke

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • norfolk
  • Posts: 5
    • omega 3.2 elite
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #6 on: 01 May 2017, 12:12:39 »

Ok thanks for replies first, just an update I have installed a new battery and fine for a day, but now it has all started again and getting worse. Soon as I start the ignition the popping noises starts with radio off, then when I turn radio on it keeps doing it worse and radio cuts out and on again until I turn it off then its fine. I have took the stereo unit out and popped it back in looks fine what I can see. I found if I hold the front right speaker with my hand on it with some pressure all the other speakers pops worse and that one does nothing.
  There is an amp under back parcel shelf which I presume wires directly to the battery so maybe could be that, I have sourced the same amp and waiting for it to arrive, hard part if getting to this amp though with having to get all the parcel shelf out just to get to the screws.

I have checked the alternator readings comes up fine working as it should.
« Last Edit: 01 May 2017, 12:17:40 by bobbyduke »
Logged

bobbyduke

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • norfolk
  • Posts: 5
    • omega 3.2 elite
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #7 on: 01 May 2017, 12:15:17 »

Has anyone got any idea where on the Vauxhall omega 3.2 elite the grounds are for the amp and stereos so I can check them?
Logged

zirk

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Epping Forest
  • Posts: 10242
  • 3.2 Manual Special Saloon ReMapped and LPG'd and
    • 3.2 Manual Special Estate
    • View Profile
Re: Vauxhall omega stereo started making popping noise.
« Reply #8 on: 01 May 2017, 16:08:38 »

Your get a better response if you post your issue in the Omega Electrical and Audio Help Section as not everyone reads the Newbie Section.

Just for info, NCDC HU's can be removed and re inserted (Not swapped) without the need for Codes as there Security Paired to the Car Display, Yes, the Amp (Bose) is under the Parcel Shelf on the Saloons, the Speakers are driven from the Amp.

For Fault finding purposes, you could wire a speaker(s) directly to the rear of the HU speaker outputs (ie by pass the Amp) it will only give a couple of Watts, but will be enough to drive a speaker, this could be useful to determing whether the noise is coming from the HU outputs its self or from the Amp, theres a breakout / joint connector between the HU and the Amp behind the Drivers Footwell Panel
Logged
Pages: [1]   Go Up
 

Page created in 0.214 seconds with 17 queries.