Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - REvil71

Pages: [1] 2 3 4
1
Omega Electrical and Audio Help / CD Magazine problem.
« on: 07 June 2018, 21:47:56 »
Hi.

Hope someone can help me.

Changed my cds the other day and popped the mag back in the stereo and it popped
back out. Now it wont stay in the stereo. Is this a basic fault or something more difficult.

Thanks for the replys. :y

2
Omega General Help / Lambda Sensors
« on: 22 July 2017, 17:55:44 »
Hi
Went to look at an omega the other day and noticed the pre cat sensors wires burnt out.
The guy said it happened afew weeks ago. The car drives nice so here is my question -
Is there gonna be any issues with the fact that atleast one sensor isn't connected ?
Wanna be sure b4 I consider buying.
Thanks,

3
Omega General Help / Smokey headlights.
« on: 12 June 2017, 13:44:56 »
Hi.
Chatting to a car guy the other day and he said toothpaste is excellent in cleaning and clearing foggy headlamps.
Don't know if it works but thought I would put it on here just incase it helps anyone.
Luckily mine are all clear.

4
Omega General Help / Sunroof with its own ideas.
« on: 26 March 2017, 19:45:19 »
Hi.
Just a quick note. Has anyone had this happen to them. When I sometimes close the sunroof, its gets over halfway
then decides - you know I would rather be open thanks - and opens itself back up.
Why is that?
When you do it again, no probs. And its only very rare it happens. Strange. :y

5
Omega General Help / Wiper Settings gone up the wall.
« on: 27 April 2016, 16:12:45 »
Hi.
I hope someone can help me.
My wipers have stopped working properly. I have the rain detector on the top of the windscreen
and now I have found the first setting - windscreen rain doesn't work. The second setting which is
occasional doesn't work. The only one that works is constant and quicker.
I recently had work done on it where the battery was disconnected. Is there a relay reset like the windows
and sunroof or is it more terminal.
Thanks for anyones help with this....... :'(

6
Omega General Help / Mayo in overflow. Yuck.....
« on: 24 September 2014, 15:51:47 »
Hi
I have just dropped our 2.6 elite estate off to the garage to be checked for the
faulty 'oil cooler'.
It has mayo in where there was once water.
Been told by the garage that a replacement part (once got out for number) will cost
roughly 160+vat then about 200 to flush system with the rad and all pipes
being removed.
ouch.
Is this a good overall price or does anyone know a better way to go.
Other than this, the car was mint.
Any comments greatly appreciated.......................................

7
General Car Chat / Aint Omegas GREAT>>>>>>>>>>>
« on: 21 August 2014, 09:40:42 »
Just a message because I wanted to say how good these cars are.

My wife's omega had an mot 2 months ago. 1st one since we have owned it so  unknown what we would find.
It passed with no extras except 2 new tyres please. Excellent..........

Then 2 weeks ago it was my car's turn. Again haven't had an mot on it since owning it so not sure what we
would find.
And again a pass with no extras except 2 tyres also being told how clean and free from rust was a bonus.

Not being a big head here but god damn what good cars Omegas are......
 :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y

And thanks for this site as it is extra useful......

8
Omega General Help / Fault code P0304
« on: 14 March 2014, 10:14:12 »
I have used radweld yesterday for my slight leak. Ran the car for the time. Let it cool and tested. All looked good.
Went to use the car last night and it started fine but as i went to pull away it seemed to misfire. The engine management light started to flash
so i turned it off till today.
On reading the fault i have found this code. Is it a coindecense or something nasty.

Any ideas b4 i start looking would be great.

 :y

9
Omega General Help / Car Stereo
« on: 18 February 2014, 16:49:27 »
Hi
I have an 02 elite estate which i want to replace the stereo for a new 'all walking talking one' but i dont want to loose the steering wheel
features or the information on the display. is there a kit available to keep both whatever stereo i choose to put in it?

10
Omega General Help / Saying goodbye to an old friend.
« on: 16 October 2013, 17:41:16 »
We are getting rid of our 2.5td elite r-reg estate next month when the road tax is up.

Just a quick question........... where is the best place to part with it.

It probably has a shed load of parts so breaking for someone would be useful but we dont have the space.

Any ideas would be great.

I dont have enough posts to sell this at the moment.

11
Omega General Help / slight water leak
« on: 19 September 2013, 16:04:13 »
can someone tell me what the component is underneath the reservoir  it has 2 water pipes connected to it and an electrical feed on one end

12
General Car Chat / Atlast got my dream omega.
« on: 18 August 2013, 19:38:47 »
Just had to say - changed my mv6 estate for a 3.2 elite estate.
Been hunting for 1 for along time and finally got it.
So chuffed.
Absolutely over the moon. :y :y :y :y :y :y :y :y :y :y :y :y

13
General Car Chat / Just abit of Forum knowledge please....
« on: 18 July 2013, 20:01:59 »
I am letting our omega go soon.
All i want is an honest opinion of what it is worth before i get my hopes up. haha.

It is a 'R' reg 2.5td estate elite in burgandy/red. Used every day. Drives excellent with all the usual elite extras.
Bodywork looks like it has survived a shooting range. Rust on bottom back doors.Headlights slightly misty but flew through
last mot.

Any ideas from you lot please.....

14
Omega Electrical and Audio Help / MV6 Electrical Fault.
« on: 06 July 2013, 11:44:52 »
Just took my car for a spin and on the way home i noticed the battery light was just lit, then all the dials dropped and the abs,airbag,service light and battery lights were fully lit. the engine had very little power. got it home, plugged in the code reader to find p0560. cleared this just incase - all ok until light revs and then all happened again. HELP..
where do i start to look. recently changed the battery if that makes any difference...

15
Omega General Help / MV6 Passenger Road Spring.
« on: 03 December 2012, 14:17:50 »
Can anyone tell me where the best/cheapest place to get a road spring for my mv6 is.
thanks.
PS i live near swansea

Pages: [1] 2 3 4

Page created in 0.075 seconds with 12 queries.