Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - REvil71

Pages: [1] 2 3 4 5 6 7 8 ... 11
1
Omega Electrical and Audio Help / Re: CD Magazine problem.
« on: 13 June 2018, 16:57:35 »
Cheers mate.
Found it and problem solved.

Thanks again

2
Omega Electrical and Audio Help / CD Magazine problem.
« on: 07 June 2018, 21:47:56 »
Hi.

Hope someone can help me.

Changed my cds the other day and popped the mag back in the stereo and it popped
back out. Now it wont stay in the stereo. Is this a basic fault or something more difficult.

Thanks for the replys. :y

3
Omega General Help / Re: Lambda Sensors
« on: 24 July 2017, 13:15:55 »
Thanks.
Think I will steer clear.

4
Omega General Help / Lambda Sensors
« on: 22 July 2017, 17:55:44 »
Hi
Went to look at an omega the other day and noticed the pre cat sensors wires burnt out.
The guy said it happened afew weeks ago. The car drives nice so here is my question -
Is there gonna be any issues with the fact that atleast one sensor isn't connected ?
Wanna be sure b4 I consider buying.
Thanks,

5
Omega General Help / Smokey headlights.
« on: 12 June 2017, 13:44:56 »
Hi.
Chatting to a car guy the other day and he said toothpaste is excellent in cleaning and clearing foggy headlamps.
Don't know if it works but thought I would put it on here just incase it helps anyone.
Luckily mine are all clear.

6
Omega General Help / Sunroof with its own ideas.
« on: 26 March 2017, 19:45:19 »
Hi.
Just a quick note. Has anyone had this happen to them. When I sometimes close the sunroof, its gets over halfway
then decides - you know I would rather be open thanks - and opens itself back up.
Why is that?
When you do it again, no probs. And its only very rare it happens. Strange. :y

7
Omega General Help / Re: Wiper Settings gone up the wall.
« on: 27 May 2016, 19:13:23 »
Checked relay. nope.
so next is stalk to test.

8
Omega General Help / Re: Wiper Settings gone up the wall.
« on: 24 May 2016, 18:35:44 »
Also when I squirt water, the wipers don't come on so possibly relay.

9
Omega General Help / Re: Wiper Settings gone up the wall.
« on: 23 May 2016, 16:17:03 »
Cheers. That's where I will start then...

10
Omega General Help / Re: Wiper Settings gone up the wall.
« on: 23 May 2016, 15:39:28 »
I have now found out it is a fault that needs clearing with a teck2.
Can it be reset without this or have I no option.

11
Omega General Help / Wiper Settings gone up the wall.
« on: 27 April 2016, 16:12:45 »
Hi.
I hope someone can help me.
My wipers have stopped working properly. I have the rain detector on the top of the windscreen
and now I have found the first setting - windscreen rain doesn't work. The second setting which is
occasional doesn't work. The only one that works is constant and quicker.
I recently had work done on it where the battery was disconnected. Is there a relay reset like the windows
and sunroof or is it more terminal.
Thanks for anyones help with this....... :'(

12
Omega General Help / Re: Mayo in overflow. Yuck.....
« on: 25 September 2014, 19:57:24 »
 :y cheers for the info

13
Omega General Help / Re: Mayo in overflow. Yuck.....
« on: 24 September 2014, 19:19:34 »
Yes
Cheers for the comments
Sounds like it is in the best place.

14
Omega General Help / Mayo in overflow. Yuck.....
« on: 24 September 2014, 15:51:47 »
Hi
I have just dropped our 2.6 elite estate off to the garage to be checked for the
faulty 'oil cooler'.
It has mayo in where there was once water.
Been told by the garage that a replacement part (once got out for number) will cost
roughly 160+vat then about 200 to flush system with the rad and all pipes
being removed.
ouch.
Is this a good overall price or does anyone know a better way to go.
Other than this, the car was mint.
Any comments greatly appreciated.......................................

15
General Car Chat / Aint Omegas GREAT>>>>>>>>>>>
« on: 21 August 2014, 09:40:42 »
Just a message because I wanted to say how good these cars are.

My wife's omega had an mot 2 months ago. 1st one since we have owned it so  unknown what we would find.
It passed with no extras except 2 new tyres please. Excellent..........

Then 2 weeks ago it was my car's turn. Again haven't had an mot on it since owning it so not sure what we
would find.
And again a pass with no extras except 2 tyres also being told how clean and free from rust was a bonus.

Not being a big head here but god damn what good cars Omegas are......
 :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y :y

And thanks for this site as it is extra useful......

Pages: [1] 2 3 4 5 6 7 8 ... 11

Page created in 0.083 seconds with 14 queries.