Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to OOF

Pages: [1]   Go Down

Author Topic: Small idle issue after plug change  (Read 328 times)

0 Members and 1 Guest are viewing this topic.

berserkerboy

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Llansadwrn, Carmarthenshire SA19
  • Posts: 413
    • 3.2 V6 Elite 02 LPG
    • View Profile
Small idle issue after plug change
« on: 30 September 2017, 20:39:08 »

Hi folks

Changed the plugs on my 3.2 lpg estate today. About 3 years ago I put bosch plugs in, but they were single electrode. Recently the idle has been slightly uneven, both at start up and when warm, hence the change. There was a bit of oil in the wells which I am not entirely surprised about. Will look to do the cam gaskets soon. Probably damaged when the car was converted to LPG a while ago.

I put NGK triple electrodes in. Good price on CP4L. ca 19 all in.

However, the uneven idle appears to be even worse now at start up. It idles fine, then revs up a bit, goes back to fine, then revs up again etc. When the car switched into LPG I noticed the idle seemed alot smoother.

Haven't yet taken the car for a run to see how she behaves but I was wondering if anyone had any initial thoughts?
Logged

berserkerboy

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Llansadwrn, Carmarthenshire SA19
  • Posts: 413
    • 3.2 V6 Elite 02 LPG
    • View Profile
Re: Small idle issue after plug change
« Reply #1 on: 02 October 2017, 09:04:18 »

So this is still a niggling problem. Seems worse at start up. I'll see if there are any codes today. Car seems fine out on a trip.
Logged

TheBoy

  • Administrator
  • *********
  • Offline Offline
  • Gender: Male
  • Brackley, Northants
  • Posts: 96733
  • Millennium Man
    • Anything that goes
    • View Profile
Re: Small idle issue after plug change
« Reply #2 on: 02 October 2017, 18:26:03 »

What are trims doing on petrol?

Triple electrode plugs aren't ideal for LPG cars, and might be highlighting a pre existing condition
Logged
I don't tolerate bickering, and I'm always grumpy.
And Lizzie Zoom says I'm a heartless bastid...and she's absolutely correct!

berserkerboy

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Llansadwrn, Carmarthenshire SA19
  • Posts: 413
    • 3.2 V6 Elite 02 LPG
    • View Profile
Re: Small idle issue after plug change
« Reply #3 on: 02 October 2017, 20:32:44 »

Typical of me :(.  Thought I was getting better plugs but it appears the single ones are probably better for LPG.

I'm sure you're right. Existing condition been highlighted.

Laptop needed to charge so didn't get a chance to get any codes today.

Not sure if my naff code reader (we all know the one)  ;) gives fuel trims.



Logged

berserkerboy

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Llansadwrn, Carmarthenshire SA19
  • Posts: 413
    • 3.2 V6 Elite 02 LPG
    • View Profile
Logged

Stige

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • Finland
  • Posts: 175
    • -68 Satellite, -97 MV6
    • View Profile
Re: Small idle issue after plug change
« Reply #5 on: 02 October 2017, 22:12:33 »

Logged

berserkerboy

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Llansadwrn, Carmarthenshire SA19
  • Posts: 413
    • 3.2 V6 Elite 02 LPG
    • View Profile
Logged
Pages: [1]   Go Up
 

Page created in 0.077 seconds with 17 queries.