Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: [1]   Go Down

Author Topic: Diagnosing faulty parking sensors  (Read 1303 times)

0 Members and 1 Guest are viewing this topic.

Doctor Gollum

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 7351
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Diagnosing faulty parking sensors
« on: 02 March 2015, 21:16:49 »

This works on almost any parking sensor, regardless of manufacture. Certainly works on GM'S park pilot as fitted to face lift omegas.

No extra software or pulling relays required, in order to count bleeps relating to which sensor, or messing about looking up the code on the Internet.

Simply place the car in reverse with ignition on, engine off. Walk round to the sensor and lightly touch the central part of the sensor until you hear a slight tick. Obviously a bit of quiet helps, but the results are immediately obvious as a sensor that doesn't tick ain't working. Seemples :y


Although, it could easily be the loom of course. But with this info you can easily diagnose which sensor or which arm of the loom is playing up by swapping plugs and sensors around to count out the working or not working components, once the bumper is removed and supported for access to the back of the bumper. The loom isn't long enough to reach the floor. So a stool or beer crate is handy to support the bumper while you fiddle.

Note;
1) try to avoid spraying switch cleaner in the loom plug as the silicon seals swell up and it's a swine to re fit the plug.

2) in my experience a sensor that's fitted in too tight a hole tends to play up intermittently. This is annoying as once removed and re fitted they then work. Only to play up once again when the bumpers back on needing a repeat removal.

On selecting reverse Parkpilot gives;

In normal working mode.
A single beep when reverse is selected.
Then increasing beeps approaching an object, to constant tone indicating an obstruction is less than 6 inches from the bumper. (Stop obviously)



If faulty;
Constant tone.
Signifies a fault. Sensors not working. Use above procedure to diagnose the faulty sensor(s)

No tone at at all.
No power to Parkpilot unit.
Or more usually a failed speaker. Usually located above the head lining between the sunroof and the left b pillar. Follow the braided cable from the Parkpilot unit to locate.

Parkpilot unit is located in the boot, behind the spare wheel, and then behind the metal upright support by the skin of the rear wing.

Hope helps.

Logged
Onanists always think outside the box.
Pages: [1]   Go Up
 

Page created in 0.079 seconds with 16 queries.