Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Pages: [1] 2  All   Go Down

Author Topic: 2.0 Idle hunting  (Read 1228 times)

0 Members and 1 Guest are viewing this topic.

ians

  • Omega Baron
  • ******
  • Offline Offline
  • Reading
  • Posts: 3389
    • View Profile
2.0 Idle hunting
« on: 17 March 2007, 11:11:54 »

I have just cleaned out the breathers, throttle and IVC on my 2.0DOHC.

The small breather port into the throttle was solid as predicted by others on here, but is now clear.  Otherwise I gave everything a good clean up
- throttle body, ICV, hoses - except the small bore hose which I have replaced.

The main reason for doing this was to improve idleing,  but now instead of occassional stalling I'm getting a dramatic 'hunting' effect.  When under no throttle - idle or overrun - the revs are moving between about 1500 and 2000 rpm.   I've checked all connections (I think) and all looks fine.

More specifically the first time I started it up it ran fine - I let it idle for 10 minutes on the driveway and all ok.
Then put it back in the garage and this problem started happening.
Then took it for a run in the blind hope it might sort itself out.  30 mins or so later it is still doing it - most but not all the time.   I get the impression that when its a bit hot (needle rises when I'm in traffic - always has) the problem is less.

No orange light.

I'm wondering if something is sticking (butterfly or ICV?) as a result of my clean up, or if clearing the small port has provoked this (I could always block the pipe to simulate recreating the blocked port).

Appreciate any suggestions...

Cheers,
Ian
Logged

Fuse 19

  • Administrator
  • *********
  • Offline Offline
  • Gender: Male
  • West Bridgford
  • Posts: 31769
  • Git!
    • View Profile
Re:  2.0 Idle hunting
« Reply #1 on: 17 March 2007, 11:38:02 »

Is the throttle butterfly fully shut with the throttle released and the cable has some slack in it?

Any hissing or signs of air leaks....?
Logged

ians

  • Omega Baron
  • ******
  • Offline Offline
  • Reading
  • Posts: 3389
    • View Profile
Re:  2.0 Idle hunting
« Reply #2 on: 17 March 2007, 11:46:00 »

Mark - how can you check the butterfly is closed with the air intake ducting in place - or should I remove that?  (Sorry this may be obvious if I go and look at the car).   My first thought was that the throttle cable was tight and not at its end stop but I adjusted that -may be worth another look though.

No obvious signs of hissing/leaks - I was inspecting that area pretty closely.   I know I reconnected the vacuum hose to the back of the throttle body.
Logged

Fuse 19

  • Administrator
  • *********
  • Offline Offline
  • Gender: Male
  • West Bridgford
  • Posts: 31769
  • Git!
    • View Profile
Re:  2.0 Idle hunting
« Reply #3 on: 17 March 2007, 11:56:07 »

One of the classic bodges on these units for stalling is for a mechanic to adjust the throttle stop so the butterfly never fully shuts.

You need the inelt duct off to check.....easy enough though.

I usualy adjust the screw until you feel the throttle stick and then wind it in a bit.......other than this your looking for leaks or  A breather which are off.....I assume the oil cap is on....
Logged

ians

  • Omega Baron
  • ******
  • Offline Offline
  • Reading
  • Posts: 3389
    • View Profile
Re:  2.0 Idle hunting
« Reply #4 on: 17 March 2007, 12:04:20 »

Thanks for the suggestions Mark - I'll have another poke around.

I'm pretty sure the butterfly was closed when I was cleaning it, but I'll whip the ducting off and have a look.



  
Logged

Auto Addict

  • Administrator
  • *********
  • Offline Offline
  • Gender: Male
  • North Birmingham
  • Posts: 12728
  • Oil burner
    • MB C-class Estate
    • View Profile
Re:  2.0 Idle hunting
« Reply #5 on: 17 March 2007, 15:48:39 »

Had a similar problem on a mates 2.0, adjusted the throttle cable and everything was fine.
Logged
Crown Green Bowler

ians

  • Omega Baron
  • ******
  • Offline Offline
  • Reading
  • Posts: 3389
    • View Profile
Re:  2.0 Idle hunting
« Reply #6 on: 20 March 2007, 13:28:05 »

Since posting I've taken the car on a few runs.

The idling is still erratic.  Sometimes hunting as described between c 1500 and 2000rpm, sometimes stable at a fast idle 1500, sometimes normal 6-700.   Blipping throttle doesn't seem to help, although driving a bit and then coming to a stop again can result in different behaviour.

I tried pulling off the small breather hose from the cam housing - there is significant vacuum in it (I guess there wasn't before as the hose/port was totally blocked), but having it open to atmosphere or blocking it has no effect.

Given the intermittent nature, I'm wondering if either throttle butterfly or ICV are sticking occassionally.   Somewhere I have got an old ICV (before I was enlightened I changed it to address the common stalling issue) - may try that to see what happens.

Ideally I'd like to stop the car when its hunting, whip the intake ducting off and check if the butterfly is open a bit, but I've not been able to recreate that scenario in a convenient situation (middle lane of the M4 in rush hour not good idea!)

Any further suggestions welcome of course!

Cheers
Ian
Logged

Martin_1962

  • Guest
Re:  2.0 Idle hunting
« Reply #7 on: 20 March 2007, 13:58:30 »

Check for air leaks around the throttle body

Does the ICV move smoothly?
Logged

Craig_R

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Male
  • Watford
  • Posts: 1244
    • View Profile
Re:  2.0 Idle hunting
« Reply #8 on: 20 March 2007, 14:10:01 »

Mine Does this also But only on LPG

The Needle hunts around the 1000 mark say about 800 to 1100 sometimes.

It has only started since I replaced the Lambda Sensor it did it on petrol but stopped after about 5 miles i think the ECU was resetting itself to the new Lambda sensor Working.

I had a Good Look For Air Leaks on Sunday removed the Throttle Body checked the new gasket i had put on and it all looked fine.

ill have to have a look at the ICV again see if its sticky

Craig
Logged
Mod's
LPG, MV6 Dark Grey Leather, Carputer, Euro Grill, Rear Sun Blind,  Auto Dip Mirror, Cruise Control, AMP for Carputer
[To be Fitted]Reverse Sensors

sefton

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 44
    • View Profile
Re:  2.0 Idle hunting
« Reply #9 on: 05 April 2007, 07:52:02 »

Hi Ian & Craig,
Have you got to the bottom of this problem yet? I am getting exactlty the same symptoms as you.  I have cleaned all the breathers including the rear sump pipe (that was really gunged up) and cleaned the throttle body and ICV.  Checked the butterfly is closed fully and there is slack in the throttle cable. Still just the same.  I don't know what to try next.
Alan.
Logged

Craig_R

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Male
  • Watford
  • Posts: 1244
    • View Profile
Re:  2.0 Idle hunting
« Reply #10 on: 05 April 2007, 10:00:24 »

I think I have gotten to the bottom of my problem it was to do with the Gas system but i did changed the Exhaust Manifold after it had a huge crack and that seemed to help but it could of been a coincidence. but i did also change the one way valve for the secondary air injectors as it was knacked.

Mine still hunts very very slightly on gas only but only to the point now of the rev needle now and again moving slightly i can live with it.

Just a thought i would check all the air intake pipes for leaks and check the air filter also as it was one of the things i changed

Craig
Logged
Mod's
LPG, MV6 Dark Grey Leather, Carputer, Euro Grill, Rear Sun Blind,  Auto Dip Mirror, Cruise Control, AMP for Carputer
[To be Fitted]Reverse Sensors

sefton

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 44
    • View Profile
Re:  2.0 Idle hunting
« Reply #11 on: 05 April 2007, 10:09:03 »

Thanks Craig, I'll have another look. It's starting to do my head in!
Alan.
Logged

ians

  • Omega Baron
  • ******
  • Offline Offline
  • Reading
  • Posts: 3389
    • View Profile
Re:  2.0 Idle hunting
« Reply #12 on: 05 April 2007, 12:30:30 »

Hi Sefton,

Not yet - job for the weekend.

Plan of attack
- disassemble ICV and throttle body , check not sticking and lubricate with 3 in 1
- again check for loose/split hoses
- try my old ICV - this used to cause stalling, but we'll see if it makes any difference
- use new gaskets for TB and ICV.

If that doesn't fix it I'm stuck for ideas.

Cheers

Ian
Logged

sefton

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 44
    • View Profile
Re:  2.0 Idle hunting
« Reply #13 on: 05 April 2007, 13:06:15 »

I've tried all that Ian. No luck, in fact I think that it's probably worse! It's idling at up to 2000 revs now and being an auto it makes it very awkward to drive. (Brakes are good though!)
Alan.
Logged

ians

  • Omega Baron
  • ******
  • Offline Offline
  • Reading
  • Posts: 3389
    • View Profile
Re:  2.0 Idle hunting
« Reply #14 on: 05 April 2007, 13:09:42 »

Have you tried a different ICV?

I chenged mine a year or so ago and still have the old one in the garage.
Logged
Pages: [1] 2  All   Go Up
 

Page created in 0.098 seconds with 17 queries.