Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Pages: 1 2 3 4 5 6 [7]   Go Down

Author Topic: Omega 24v Work in Progress  (Read 5793 times)

0 Members and 1 Guest are viewing this topic.

grifter

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Paisley, Scotland
  • Posts: 340
  • Omega 2.6 owner
    • Omega 2.6
    • View Profile
Re: Omega 24v Work in Progress
« Reply #90 on: 08 June 2017, 01:04:54 »

Each front hub/axle is bolted to the McPherson strut using two bolts. One of the bolt holes is slotted to allow adjustment.

Wear in the bushes will allow some movement but it is failure to adjust the camber using these bolts which is the cause of that much camber.

Same as the Senator. In short term I will likely have a go at setting it up using the socket spacer method I've seen on here. Mainly to get it over the winter months, and minimise wear, when I won't be using it much anyway. Timing belt is the first and most important thing I need to change.

As an aside, was reading through this thread at work I've done etc. and I remembered I'd checked my cavy (with fixed camber afaik) camber and it was much the same. I'd imagine a wheel should be perpendicular to the road, even a couple of mils out you would think uneven tyre wear but no not really. There must be a reason it is set like this, some mechanical sophisticatory that us mere mortals don't understand.
Logged

grifter

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Paisley, Scotland
  • Posts: 340
  • Omega 2.6 owner
    • Omega 2.6
    • View Profile
Re: Omega 24v Work in Progress
« Reply #91 on: 13 September 2017, 13:33:29 »

Small update: fixed scuttle leak. Sealed the join on n/s and sealed wiper hole on o/s with panel sealant. Dried out coil packs, look ok. One got a wee crack at base but no rust. Took plugs out. They were very hard to undo, and 5 of them broke, so got new ones from vx dealer. Due to rebuild it all tonight if it doesn't rain!
Logged

grifter

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Paisley, Scotland
  • Posts: 340
  • Omega 2.6 owner
    • Omega 2.6
    • View Profile
Re: Omega 24v Work in Progress
« Reply #92 on: 14 September 2017, 06:35:28 »

Seems to be running ok now, after a kind of noisy start up. Got me worried. It sounded like a tappety noise, maybe sticky tappet. It disappeared then reappeared, but eventually went quiet.
Logged

Andy H

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Cornwall
  • Posts: 4999
    • 3.2 Project MV6 Estate
    • View Profile
Re: Omega 24v Work in Progress
« Reply #93 on: 14 September 2017, 15:10:24 »

Probably lazy cam followers/tappets.

If it only does it from cold then it might be the exhaust manifold gaskets.
Logged
"Deja Moo - The feeling that you've heard this bull somewhere before."

grifter

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Paisley, Scotland
  • Posts: 340
  • Omega 2.6 owner
    • Omega 2.6
    • View Profile
Re: Omega 24v Work in Progress
« Reply #94 on: 20 September 2017, 22:22:02 »

Probably lazy cam followers/tappets.

If it only does it from cold then it might be the exhaust manifold gaskets.

Thinking the same thing. It went away after 5 mins and then when I tapped the throttle a little it came back then went away after a couple of mins. Seems ok now. I did an oil change on it but I don't think I flushed it. Will do that next oil change give it a good flush.
Logged

grifter

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Paisley, Scotland
  • Posts: 340
  • Omega 2.6 owner
    • Omega 2.6
    • View Profile
Re: Omega 24v Work in Progress
« Reply #95 on: 06 December 2017, 07:21:13 »

Next job i think is flush and oil & filter change in box as up change is still a bit sticky. It looks like the same box as in senator if not mistaken, small sump and large sump. If so i d have spare gaskets. Have also started aquiring rear exhaust bits, can only afford one bit a month. Need to get 2 centre sections next.

Still not convinced scuttle is properly sealed, either that or water is leaking in wiper hole to engine bay. Not suffered leak into passenger floor again, checked drain and is clear so would love to know how that water got in. Hopefully it was the little bit of bulkhead join i sealed with grease. There was rust starting in join so i dug out all dried sealant and rust treated it but hadn't sealed it at the time.

Logged
Pages: 1 2 3 4 5 6 [7]   Go Up
 

Page created in 0.076 seconds with 16 queries.