Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: [1]   Go Down

Author Topic: Instrument panel lights not working.  (Read 212 times)

0 Members and 1 Guest are viewing this topic.

neil74

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • newport
  • Posts: 236
    • 2.5 elite estate.
    • View Profile
Instrument panel lights not working.
« on: 27 November 2017, 21:49:40 »

Can someone help with a little problem I have. basically when I switched on the lights the other day smoke started pouring from the switch so I popped the bonnet and disconnected the battery just to be on the safe side. but now I don't have any instrument panel or radio lights at all and despite checking fuses and swapping the circuit board inside the switch I cannot get any illumination. does anyone have any suggestion as to the problem.

Thanks
All.
Logged

Entwood

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • North Wiltshire
  • Posts: 18737
  • Quietly Confident
    • Elite 3.2 V6 (LPG)
    • View Profile
Re: Instrument panel lights not working.
« Reply #1 on: 27 November 2017, 21:59:18 »

Can someone help with a little problem I have. basically when I switched on the lights the other day smoke started pouring from the switch so I popped the bonnet and disconnected the battery just to be on the safe side. but now I don't have any instrument panel or radio lights at all and despite checking fuses and swapping the circuit board inside the switch I cannot get any illumination. does anyone have any suggestion as to the problem.

Thanks
All.

At a guess .. new switch needed .. :(
Logged
V6 Cam locking/setting kit, Maxscan GS500 OBDII code reader/EML resetter available.  

zirk

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Epping Forest
  • Posts: 10290
  • 3.2 Manual Special Saloon ReMapped and LPG'd and
    • 3.2 Manual Special Estate
    • View Profile
Re: Instrument panel lights not working.
« Reply #2 on: 28 November 2017, 10:10:57 »

As said switch, or probably the little dimmer slider switch has burnt out.
Logged

neil74

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • newport
  • Posts: 236
    • 2.5 elite estate.
    • View Profile
Re: Instrument panel lights not working.
« Reply #3 on: 28 November 2017, 10:32:42 »

I did replace the board from a supposed working switch but like I said not a jot of light. but up until that point the dimmer never worked and the lights were at full brightness wherever the control was. I don't suppose anyone has a good switch they could sell me do they..
Logged

neil74

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • newport
  • Posts: 236
    • 2.5 elite estate.
    • View Profile
Re: Instrument panel lights not working.
« Reply #4 on: 09 December 2017, 23:03:17 »

Should hopefully be sorted once the switch arrives.thanks Jon  :y

Logged

neil74

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • newport
  • Posts: 236
    • 2.5 elite estate.
    • View Profile
Re: Instrument panel lights not working.
« Reply #5 on: 14 December 2017, 12:44:12 »

Well Jons switch arrived and I clipped it into the dash and guess what it popped just like the first one. can anyone else suggest where to look for the problem as I've already knackered two switches and its getting rather expensive.
Logged
Pages: [1]   Go Up
 

Page created in 0.072 seconds with 16 queries.