Omega Owners Forum

Omega Help Area => Omega General Help => Topic started by: 2boxerdogs on 20 October 2012, 17:45:53

Title: Coolant level warning on.
Post by: 2boxerdogs on 20 October 2012, 17:45:53
 Hi guys, whilst out & about today in the 2.2 the computer displayed check coolant level warning, car temperature was fine & was running perfectly, got home checked coolant all fine went out a couple of hours later & warning came on again any ideas ? A new timing belt kit & water pump was fitted about about a month ago could this be connected ?
Title: Re: Coolant level warning on.
Post by: doz on 20 October 2012, 17:48:34
Check it when it's stone cold. It doesn't have to be much below the lower line to trip
Title: Re: Coolant level warning on.
Post by: tunnie on 20 October 2012, 17:54:04
Sounds like the float is sticking, with engine cold poke your finger into the coolant bottle and wiggle the float.

If its failed, they are only about 35 new & make engine bay look so much better!
Title: Re: Coolant level warning on.
Post by: 2boxerdogs on 20 October 2012, 18:20:50
Thanks, will check in the morning sounds like it could be an easy fix!!
Title: Re: Coolant level warning on.
Post by: PhilRich on 20 October 2012, 19:36:36
Don't forget to check the plug connector is firmly pushed home on the base of the tank. :y
Title: Re: Coolant level warning on.
Post by: zirk on 20 October 2012, 19:37:30
Also check the connector (under header tank) is not loose, intermittent or gone rusty. or someone has not bodged it with a paperclip.


Edit, slow fingers ;)
Title: Re: Coolant level warning on.
Post by: 2boxerdogs on 21 October 2012, 15:25:42
Checked tank float this morning all free , then connector under tank, appears clean & well connected, bridged wire connector & check light went out. So presume it is the switch part which is attached to the tank,is this part available on its own or is it part of the tank?
Title: Re: Coolant level warning on.
Post by: zirk on 21 October 2012, 15:30:43
Checked tank float this morning all free , then connector under tank, appears clean & well connected, bridged wire connector & check light went out. So presume it is the switch part which is attached to the tank,is this part available on its own or is it part of the tank?

Part of the Tank, so new one, fairly common fail.
Title: Re: Coolant level warning on.
Post by: drf_omega on 21 October 2012, 16:01:00
Yes, part of the tank! Had the same problem, easily fixed after getting a replacement tank. It's easy to change, no problem at all.
Title: Re: Coolant level warning on.
Post by: 2boxerdogs on 21 October 2012, 16:32:38
Thanks guys will order one next week.