Omega Owners Forum

Omega Help Area => Maintenance Guides => Topic started by: Entwood on 07 October 2015, 14:28:57

Title: Changing a Front ABS Sensor
Post by: Entwood on 07 October 2015, 14:28:57
Changing the front ABS sensor is covered in Haynes manual on page 9.18 para 46 with a glib one liner ...

Unscrew the mounting bolt using a Torx key and withdraw the sensor from the mounting bracket

I wish it was that simple .... this is what I had to do..

With the car suitably supported on stands, remove the road wheel

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0890.jpg)

On the rear of the wheel can be found the sensor and its securing bolt. This one has been liberally dosed in plusgas for a few days ... probably needn't have bothered :(

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0893.jpg)

There was no way it was going to move, even with a thin bladed screwdriver in the "slot" on the back .. and no access to anything at the front.

So, Brake Caliper off and tied up out of the way, then Caliper Retaining bracket off

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0896.jpg)

Remove the Disc retaining screw

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0897.jpg)

then remove the disc itself ... might take a bit of beating with a rubber mallet

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0898.jpg)

Once the disc is off the reluctor (toothed wheel) and a small portion of the ABS sensor can be seen

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0900.jpg)

At this point I tried a large flat bladed screwdriver levering on the front of the ABS sensor, whilst at the same time using a small bladed one in the slot at the rear ... all that happened was the casing broke and the innards came out leaving the casing in the hole  :(

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0901.jpg)

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0902.jpg)

So, centre cap off to reveal the hub nut

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0903.jpg)

Then undo the hub nut with a long breaker bar and a 32mm socket . It is done up to 320Nm so takes a bit of leverage to move. Once off the whole hub and bearing assembly slides off very easily. The ABS sensor area is then fully accessible

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0905.jpg)

Comparing the new sensor to some sockets and an 11mm socket seemed to suit

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0906.jpg)

This was then used to knockout as much of the broken casing as possible.

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0908.jpg)

Some bits had to be pried out with a screwdriver, the hole was then cleaned up with a wire brush

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0910.jpg)

The new sensor was then inserted... its a VERY tight fit and even with a little copperslip applied took some gentle taps with a rubber mallet to fit... I took a LOT of care to ensure the mounting hole was aligned as once in I doubt I could have turned the sensor

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0911.jpg)

Then to reassemble... hub back on but leave the centre cap off, bit of copperslip ready for the disc. My torque gauge only goes to 210 Nm .. so that's what I used .....there is a reason for leaving the cap off ....

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0913.jpg)

Disc and caliper mounting bracket and back on

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0914.jpg)

Then the caliper and pads, taking care not to break the pad wear sensor - note to self ...new discs and pads needed before the MOT in January !!  :(

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0916.jpg)

Because I'd been handling the disc so putting greasy marks all over it, both inner and outer surfaces cleaned up with brake cleaner. Touch of copperslip ready for the wheel itself

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0917.jpg)

Remove the centre boss from the road wheel and refit

(http://images.omegaowners.com/images/guides/abs_ecu_sensor/IMG_0918.jpg)

Let down from stands and jack, torque up the wheel bolts. On startup the warning lights for ABS/TC went out immediately, a couple of brake presses to set the pads properly and a quick road test showed the ABS and TC was working properly.

So, drive to local garage where, for 2 in the "Help the Heroes" box they torqued up the hub bolt to 320 Nm without having to do anything else for access. I drove home, removed the wheel, fitted the centre cap to the hub nut, fitted the centre boss to the wheel and refitted the wheel.

Probably not the easiest way, but it worked. Torque wrench took a lot of use as there are a few torque sensitive bolts to do up, but the only "special" tool needed was the high range torque wrench .. all the other spanners and sockets were in the Halfords set

Hope this helps someone in the future !