Omega Owners Forum

Omega Help Area => Omega General Help => Topic started by: berserkerboy on 30 September 2017, 20:39:08

Title: Small idle issue after plug change
Post by: berserkerboy on 30 September 2017, 20:39:08
Hi folks

Changed the plugs on my 3.2 lpg estate today. About 3 years ago I put bosch plugs in, but they were single electrode. Recently the idle has been slightly uneven, both at start up and when warm, hence the change. There was a bit of oil in the wells which I am not entirely surprised about. Will look to do the cam gaskets soon. Probably damaged when the car was converted to LPG a while ago.

I put NGK triple electrodes in. Good price on CP4L. ca 19 all in.

However, the uneven idle appears to be even worse now at start up. It idles fine, then revs up a bit, goes back to fine, then revs up again etc. When the car switched into LPG I noticed the idle seemed alot smoother.

Haven't yet taken the car for a run to see how she behaves but I was wondering if anyone had any initial thoughts?
Title: Re: Small idle issue after plug change
Post by: berserkerboy on 02 October 2017, 09:04:18
So this is still a niggling problem. Seems worse at start up. I'll see if there are any codes today. Car seems fine out on a trip.
Title: Re: Small idle issue after plug change
Post by: TheBoy on 02 October 2017, 18:26:03
What are trims doing on petrol?

Triple electrode plugs aren't ideal for LPG cars, and might be highlighting a pre existing condition
Title: Re: Small idle issue after plug change
Post by: berserkerboy on 02 October 2017, 20:32:44
Typical of me :(.  Thought I was getting better plugs but it appears the single ones are probably better for LPG.

I'm sure you're right. Existing condition been highlighted.

Laptop needed to charge so didn't get a chance to get any codes today.

Not sure if my naff code reader (we all know the one)  ;) gives fuel trims.



Title: Re: Small idle issue after plug change
Post by: berserkerboy on 02 October 2017, 21:15:46
Perhaps I should get these.

http://www.ebay.co.uk/itm/6x-Vauxhall-Omega-3-2-V6-Genuine-Bosch-Super-Plus-Spark-Plugs-/361609125952?fits=Model%3AOmega&hash=item5431956040:g:BRgAAOSw4A5Yy4TK

Title: Re: Small idle issue after plug change
Post by: Stige on 02 October 2017, 22:12:33
Perhaps I should get these.

http://www.ebay.co.uk/itm/6x-Vauxhall-Omega-3-2-V6-Genuine-Bosch-Super-Plus-Spark-Plugs-/361609125952?fits=Model%3AOmega&hash=item5431956040:g:BRgAAOSw4A5Yy4TK

Is that price really for 6 plugs?   :o
In Finland we probably have to pay that much for a single plug...
Title: Re: Small idle issue after plug change
Post by: berserkerboy on 03 October 2017, 09:14:27
Perhaps I should get these.

http://www.ebay.co.uk/itm/6x-Vauxhall-Omega-3-2-V6-Genuine-Bosch-Super-Plus-Spark-Plugs-/361609125952?fits=Model%3AOmega&hash=item5431956040:g:BRgAAOSw4A5Yy4TK

Is that price really for 6 plugs?   :o
In Finland we probably have to pay that much for a single plug...
Yep. 8)