Omega Owners Forum

Omega Help Area => Omega Electrical and Audio Help => Topic started by: Big Rod on 27 July 2006, 21:36:02

Title: CD changer question.
Post by: Big Rod on 27 July 2006, 21:36:02
SWMBO's Elite has a 6 disk Blaupunkt changer in the boot.

When I bought it, there was no cartridge with it, so someone I know through the Autobahnstormers kindly provided one for me.

So I went out tonight to install it with some CD's.

It took the cartridge alright and loaded and ejected all the CD's as part of it's self test, (I assume), and it would eject the cartridge when I pressed the button, so I know there's power and some sort of intelligence there, but when I press the CD button on the boogie box, it says "No CDC".

Any ideas?

TIA!
Title: Re: CD changer question.
Post by: RossPhim on 28 July 2006, 08:29:50
Stupid question here, but here goes.
Have you put the CD's in the correct way round?
Title: Re: CD changer question.
Post by: TheBoy on 28 July 2006, 10:43:19
When you push the magazine back into cd changer, do the MID go through CD1,CD2,CD3,CD4,CD5,CD6 sequence as it checks which disks are in?
Title: Re: CD changer question.
Post by: Fuse 19 on 28 July 2006, 10:53:51
Stick a lense cleaner through it as a first off...
Title: Re: CD changer question.
Post by: Big Rod on 28 July 2006, 12:09:14
There's no such thing as a stupid question. I thought I'd put them in correctly, but I might be wrong. I'll try again.

Didn't notice the MID doing the check, but again, I'll try again.

Lens cleaner's probably a good idea as a matter of course. The rest of the car's a bit 'doggy', so the CDC might've suffered too.

Thanks guys!!