Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please play nicely.  No one wants to listen/read a keyboard warriors rants....

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Conradh

Pages: [1]
1
I went with Adrian flux in the end as it was one of the only insurers with the best price willing to insure an omega. It is twice the price of my Carlton which is only 5 years older and I have no problem finding insurers for it.

2
Iíve got my 1998 on a classic policy for last 2 years with Adrian flux.  Also agreed value.  There are few insurers who will insure Omegaís like this as apparently theyíre on an excluded list (whatever that means!). I find this odd as thereís not many left on the road now.

3
Omega General Help / Re: Temp gauge/fans
« on: 08 October 2018, 21:29:14 »
I was going to put a similar post on here as my 2.5 does a similar thing. I usually only run it in the summer months and thereís so much heat that comes off it.  When you get out you feel the heat from under the car.  I put it down to the air con.  Thatís said now the outside temp has dropped it still seemed to me to be running hot with the fan on all the time and when you turn it off they continue to run for a while.  Itís never overheated so far even in the 30 odd degrees we had this summer.  It usually runs at the 95-97 mark.  Sounds like the fan running after turning it off is normal?

4
Omega General Help / Re: Steering column top bearing
« on: 11 May 2018, 16:26:48 »
Iím sure the testers have to give out a certain number of advisories per month or something.  Iíve had some odd ones in the past on my other Carís.  One was an oil leak on my Carlton.  They said most Vauxhallís usually have an oil leak. I asked where it was coming from and they couldnít answer that question.

5
Omega General Help / Re: Steering column top bearing
« on: 11 May 2018, 16:22:13 »
Ha thatís right wish it had not been discontinued!

6
Omega General Help / Steering column top bearing
« on: 11 May 2018, 10:24:32 »
Just had a MOT on my 1998 2.5v6 Elite and it has an advisory - the Steering column top bearing slightly worn.  Spoke to Vauxhall who said itís not been discontinued.  Does anyone know where I can get one? 

7
Omega Electrical and Audio Help / Re: Power sounder issues
« on: 22 November 2017, 23:03:05 »
Thanks for your help,  think it will be goin into the nearest bin!

8
Omega Electrical and Audio Help / Re: Power sounder issues
« on: 21 November 2017, 21:25:56 »
Thatís what Iím thinking it could be as simple as changing the car battery but thatís more expense if itís not whatís going to solve it.  It might be easier just to remove it then problem solved  :)

9
Omega Electrical and Audio Help / Re: Power sounder issues
« on: 21 November 2017, 19:39:47 »
Thanks for all your replies.  Nothing is showing up in the alarm log so I discounted it to do with the bonnet switch setting it off, or something similar.  Ironically it seems ok when itís parked up and locked...

10
Omega Electrical and Audio Help / Re: Power sounder issues
« on: 21 November 2017, 17:09:35 »
Yes I read DaveDNDís post and found it very helpful.  I would like to throw it in the nearest bin but it wasnít cheap.  Are there any other associated problems with just removing it?  e.g the Horn going off instead.  Does it need Tech2 (or similar) to say itís been removed?  Iím assuming from your replies youíve removed it from your cars.

11
Omega Electrical and Audio Help / Power sounder issues
« on: 21 November 2017, 15:41:30 »
Iíve got at 1998 2.5 Elite and the powersounder was going off at random times (mainly while driving).  There was no way to stop it but it would got off for 10 seconds at most.  Having read what felt like every post/article on powersounder issues I felt that a new powersounder would sort the issue.  Having acquired a new (manufactured in 2008) one and fitted it it seems to be going off more than the old one I took off.  Again itís mainly while driving or occasionally when parked up and locked.  Spoke to Vauxhall dealer who I bought it off and they were very helpful saying ďcheck the wiringĒ.  Iíve also spoken to a non-Vauxhall specialist who said it need to be re-programmed but I donít believe this to be true?  My next thought is to replace the main car battery but Iím not sure if this will sort it.  Could a poor main battery cause it to go off while driving?  Or is it more likely to be something else like the wiring? 

Pages: [1]

Page created in 0.123 seconds with 21 queries.