Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please play nicely.  No one wants to listen/read a keyboard warriors rants....

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - egcc

Pages: [1] 2 3 4 5 6 7 8 ... 11
1
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 16 June 2019, 16:37:18 »
did you take the glove box out.

Hi yes

2
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 14 June 2019, 17:53:49 »
Yes All Sorted Have Heating Again  :D :y

3
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 14 June 2019, 11:02:55 »
Finally got it out... pushed one tag outwards and with a small thin flat screw driver got it in the lip of the resistor moved it down a couple of millimeters .... pushed back the other tag and again found a lip with the screw driver ... moved the unit down gently till finally i could pull it with my fingers... wow relief and a few scratches lol but its out lol.
Thank you all so much for your advice  :y

4
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 14 June 2019, 10:25:38 »
 :y Will give it a go Appreciate your help

5
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 13 June 2019, 21:53:14 »
Managed  to test the resistor .... faulty... blower works great with a direct feed to the battery.. gave up trying to remove the resistor lol  damn my body n arms cant bend that much lol  disconnected it  might have a go tomorrow or somebody else do it ... i see 2 lugs either side im guessing they have to be pushed outwards while pulling the unit out... if so hard to do unless they have a tool.... any tips lol

6
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 13 June 2019, 12:51:28 »
WOW thanks for all your advice :y :y .... will try this tomorrow have a part number (90512510) includes air con climate control as my unit is .. from vauxhall in manchester abd the part is available for 35

7
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 13 June 2019, 09:33:02 »
Hi How do i test it......  is it a long wire from the main battery say the live and touch both motor connectors on the hedghog ... sorry i am not technical  :-[

8
Omega Electrical and Audio Help / Re: Heater blower fan motor
« on: 13 June 2019, 09:31:45 »
Hi How do i test it......  is it a long wire from the main battery say the live and touch both motor connectors on the hedghog ... sorry i am not technical  :-[

9
Omega General Help / Re: Heater Fan/Blower Does Not Run
« on: 12 June 2019, 23:10:54 »
Hi thanks for the information much appreciated...
can you please advise if it  this one   https://www.ebay.co.uk/i/332809206421?chn=ps

if it is at fault i would prefer a vauxhall part but i doubt they would still make them due to my cars age any advice on where to get a good one from would welcome
thanks
Dave

10
Omega General Help / Heater Fan/Blower Does Not Run
« on: 12 June 2019, 21:55:23 »
Omega 2003 2.6 Facelift

Suddenly stopped working today

All digital display/functions operate normally but the heater blower will not  run at all i think i hear a very low creaky sound when i turn the heater system on and off  but the blower/fan will not operate  my system is the climate control type.
Any Ideas any fuses or  is it parts required...
Thank you in Advance
Dave

11
Omega Electrical and Audio Help / Re: Heater blower fan motor
« on: 12 June 2019, 21:50:56 »
Hi all, i may have a similar  problem.... Omega 2003 2.6

All digital display/functions operate normally but the heater blower will not  run at all i think i hear a very low creaky sound when i turn the heater system on but the blower/fan will not operate  my system is the climate control type.
Any Ideas any fuses or  is it parts required...
Thank you in Advance
Dave

12
Omega General Help / Re: 90487540 rear shock top bush omega 2003 2.6
« on: 17 December 2018, 16:52:54 »
Hi thanks i managed to get a set from vauxhall

13
Omega General Help / 90487540 rear shock top bush omega 2003 2.6
« on: 17 December 2018, 15:26:02 »
Part Number 90487540

Hi looking to replace the rear near side  top shock absorber bush mount as it is knocking badly.
Can anybody help me locate one or advise where to get one from.

Thanks all in advance

14
Omega General Help / Re: Omega 2.6 radiator 2003 Auto
« on: 10 April 2017, 20:56:44 »
 :y Thanks all.. is being checked tomorrow.

15
Omega General Help / Omega 2.6 radiator 2003 Auto
« on: 09 April 2017, 01:04:55 »
Hi all,  Have a coolant leak.... on the tray below the engine looks like I found remnants of the radiator( like strips concertina type weak alli metal) .. very brittle  too touch.. I run the engine to a hot temp and noticed  a drip passenger side near rad... think its the radiator will remove the protective  tray and hopefully see more clearly... if it is the radiator any know where to find a replacement .. the cars old but shes worth it lol .. any guesses to a second hand price replacement... thanks all.

Pages: [1] 2 3 4 5 6 7 8 ... 11

Page created in 0.144 seconds with 20 queries.