Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - TraceyCassels

Pages: [1]
1
Omega General Help / Car struggling to get started
« on: 31 January 2020, 09:14:56 »
Car still struggling to start on cold start idle very rough car shaking cutting out  miss firing having to rev it hard to keep it going  once going is fine and can stop start all day no problem but at traffic lights slight shaking  had spark plugs, coil pack crank sensor, 02 sensor done, timing belt but still have problems throttle body cleaned and cleaners through fuel system  compression test showed 10 bars and 12 bars   could fuel pump, throttle body cause this  just paid over a 1000 for repairs  would rather get some advice before I throw more money at problem as starting to think sourcing another omega might be cheaper

2
Omega General Help / Coolent warning light on
« on: 02 January 2020, 17:52:40 »
Coolent warning sign on    needle going up to 100 then going back down then going back up sign flashing on and off checked coolent and level normal oil fine as well and no signs of leak  had new ecu fitted few days before this happened  any ideas what's went wrong

3
Omega General Help / Car struggling to get started
« on: 13 December 2019, 11:40:23 »
Garage has recommended finding someone  who can look at Ecu  as showing fault  at idle 

4
Omega General Help / car struggling to start on first start
« on: 07 November 2019, 12:59:00 »
Car struggling to start on first start having to rev it to try and get it going once going its better but still running rough showing code PO170 and PO130 on code reader  just passed MOT  yesterday collected it only to bring it out garage to have same problem it went in with garage told me just run it  hard to run it when I have trouble starting it  owned car for 14 yrs  just had service done last month  its a 52 plate 106,438 milage  all garage round about me say scrap it , or run it the way it is why nobody wants to fix cars anymore is beyond me  in Southlanarkshire Scotland if anyone can help really don't want to give on car as it done me well for 14 yrs  had all brakes , handbrake , service and lots of little things done including underseal on car in the last 4 months so really want to keep car any advice help welcome

Pages: [1]

Page created in 0.123 seconds with 19 queries.