Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Vega

Pages: [1] 2
1
Has anyone installed a sandwich adapter plate oil filter for external oil cooler for a V6 yet?
I have seen that there is not a lot of room for expansion.

2
Omega General Help / looking for the HD Donuts 90539049
« on: 08 June 2018, 14:12:02 »
Anyone knows where I can find these HD donuts 90539049 if they still exists.
I know a few years back they where one eBay but now nowhere to be found.

3
Omega General Help / Drive shaft vibrations
« on: 16 April 2018, 08:46:15 »
I need some help with this problem.
Omega Y32SE 2003 automatic.

I changed the center bearing and the center support of the drive shaft, because the rubber mounting was not good anymore and now I have more vibration then before.

Things I changed after.
The two donuts where already replaced
Two drives shaft flex discs (was planned)
Engine mounts (was planned)
Gearbox mount (was planned)
The differential rubber mounts 3x (was planned)
The two horseshoe mounts, now in PU (was planned)

All this did not change anything about the vibration.

I removed the drive shaft and let it balance, drive shaft had further no defects.
Still vibrations after this action.

Next thing we did is to move the center support bearing so far as possible to the right (passenger site, for you driver site) but there is not much room but the vibration changed, not gone.
It looks like that the output shaft from the gearbox is to far to the right, is there room in the engine and gearbox mounts (or sub frame) to correct this and move the complete engine and gearbox to the left?

I did drove several saloon/estate Y26SE and Y32SE models and all of them had vibrations when taking off.

Previous I had an estate X25XE and my friends drive a X30XE and these models did not have any drive shaft vibrations after changing the drive shaft support bearing.

What is the or is there a difference in the X engine and the Y engine drive line.

If anyone has useful tips for me please let me know.

4
Omega General Help / Crank sensor mod
« on: 29 December 2017, 19:25:59 »
Don't know which jerk thought it was a good idea to put the crank sensor cable behind the exhaust manifold and let us buy again and again a new one for 100 or so because they get fried again by the exhaust manifold.
Looking at different modells I saw that the Vectra Z32SE uses a plug on crank sensor of 25, so I made a adapter cable and put it as far away form the exhaust, behind the steering box and ABS (LHD) to the engine loom.










5
Omega General Help / Modified the steering idle arm
« on: 20 July 2017, 13:06:57 »
Don't want to buy every year a new steering idle arm.
So I modified the steering idle arm, no more play, no more rubber, no more MOT issues I hope.
Two needle bearings and two seal and a lot of grease.









https://youtu.be/p_ruNi2ffwE

Do not know how long it holds, it is only a few weeks since it is on the Omega.

6
Omega General Help / 17" steel rim
« on: 09 March 2017, 14:07:24 »
Need a 17" steel rim to replace the 15" spare tire.
Not more than 6.5J and 5x110 ET33

Anyone knows of this exists?

7
Omega General Help / Aircon trouble
« on: 11 January 2017, 10:42:42 »
I need some input about the aircon system, after 4 to 6 months the system is in my 3.2 V6 Saloon again empty.
I can not find any leaks, no green stuff anywhere.

What has been done.
Condenser is replaced (was leak).
Dryer is replaced (maintenance).
AC pomp is replaced (was leak).
The 2 valves where replaced (where leak).
All maintenance on the aircon system where done by professionals.

The system works works fine, the aircon gets really cold.
But still it is leaking somewhere, so any tips are welcome.

8
Omega General Help / Bigger brakes
« on: 19 December 2016, 00:51:52 »
Did some upgrading.
Porsche calipers
Textar brake pads
Special made brackets
Goodrigde brake lines
Tarox rotors




9
When the CID/MID is removed the outside temperature sensor is not working anymore and also the heater/ecc will not work properly.

Pin 2 off the CID/MID provide the outside temperature sensor ground signal so I connected pin 2 (32 pin plug) to ground and the heater/ecc is still not working.
Fault code on the ecc is voltage to high or to low.

On pin 3 of the CID/MID provides the outside temperature sensor the temp signal and this signal also goes to ecc.
When this pin 3 (32 pin plug) is left open the ecc is not working, so I need to do something with this but not sure exactly what.

Anyone?

10
Hello,

I am looking for the air pipes of a self leveling system saloon petrol.
Pleas let me know if you have any?

Peter

11
I am looking for a Omega saloon Irmscher exhaust i 40 08 038



Shipping to The Netherlands (I know is expensive)

12
FYI.

Because there was a question in the Car Parts, bits For Sale & Wanted (not enough post to reply there) I post the information here

Maybe there are more who wants to replace a broken fog light.

Go to eBay.de and look for nebelscheinwerfer peugeot partner til 2005

They are about 25 and they are the same, bought a few my self.
They are from Depo and they where delivered with the latest facelift Irmscher Cecotto bumpers.

http://www.ebay.de/itm/Nebelscheinwerfer-Lampe-Rechts-O-S-Peugeot-Partner-Mk2-2003-2008-/301629868442?hash=item463a8a899a
http://www.ebay.de/itm/PEUGEOT-Partner-96-02-H1-NEBELSCHEINWERFER-RE-LI-TYC-/361016521415?hash=item540e42f2c7
and more

Peter

13
Hello,

I am looking for a Irmscher saloon boot spoiler facelift 2000+
If you have one to sell and will ship to The Netherlands please let me know.

Peter

14
Omega General Help / What is the right porp shaft
« on: 07 March 2015, 14:25:21 »
Can anyone tell me what the right prop shaft is, I have two models.

One with both the flange in the same direction, and one with the flange 1/3 turned.
They are both from a V6 automatic.

 

And yes one is missing the central bearing, I know. ;)

15
Omega General Help / Vibration at 20km/h (12mi/h)
« on: 18 August 2014, 18:36:59 »
I need some help with a strange phenomenon.


I have a Omega 2.6 (automatic) 2002 estate and when I start driving there is a vibration at 20 km/h (about 12 mi/h).
I test drove several 2.6 / 3.2 (automatic) saloons and estate and some of then does have the same vibration.

Anyone familiar with this vibration and does anyone know a solution.

Peter

Pages: [1] 2

Page created in 0.129 seconds with 18 queries.