Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - sefton

Pages: [1]
1
Omega General Help / 2.0 Head gasket?
« on: 29 June 2008, 16:59:05 »
Hi all.
Driving uphill this afternoon and all of a sudden got rattle from engine, started running rough and lots of whie smoke from exhaust. Had to continue driving as there was nowhere safe to stop. Then smoke disappeared and engine started running ok again. Drove home (2 miles) carefully with no problem. Car now starts and runs ok. Is this likely to be the head gasket, and if so is it a reasonable diy job? (cost?.) Or would I be better off taking advantage of the high scrap metal value at the moment?! (what does an omega weigh?). seems a shame as it has just passed its mot with very little work. Any advice would be appreciated.
Al.

2
Omega General Help / Noisy heater fan
« on: 09 December 2007, 15:44:20 »
Well, after buying the Omega in April and after sorting out the rough running (whith lots of help from you guys!), I can honestly say it has been no trouble since. It flew through the MOT in July with just an advise.
Anyway, the heater blower has always been very noisy (motor bearings?), and now it's getting more use it's starting to get on my nerves! Could anyone give me some advice as to how to get to it, and if it is an easy repair?
Thanks.

3
Omega General Help / 2.0 Air Con
« on: 17 April 2007, 13:36:28 »
Is the aircon on a 2.0 gls on all the time. I didn't realise that mine had aircon until the pump went noisy! There does not appear to be any aircon switch on the dash. Am I missing something?
Also, could anyone expalin why there are 2 temperature controls - is it front and back or left and right.  cant test properly as the heater fan sounds like it has got a cat stuck in it!
Sorry about the questions but I didn't get a handbook with the car.
Al.

4
Omega General Help / Stopped
« on: 15 April 2007, 18:30:55 »
Hi All,  After a nice run round this afternoon, I was on the last straight before home doing about 30 and the engine just stopped. Pulled over and it started again straight away no problem. There was no misfiring or rough running, it just cut out. I've done the paperclip test and the only code logged is 0340 which I beleive is the Camshaft sensor. In the guide I have it says that you should have the engine running when testing, but the EM light would not flash when I started the car, only with the ignition on. Is this normal? Also, could the camshaft sensor code be displaying because the engine was not running when tested?
Al.

5
Omega General Help / 2.0 idling between 1200 to 1800 rpm
« on: 01 April 2007, 18:04:39 »
Hi guys, I have read several posts about this problem and mine is suffering from it. It idles ok when cold and even when temp is normal it's ok, but after about 15 mins of driving the tickover hunts rapidly between 1200 and 1800 rpm. Bit of a pain. I've read about blocked breathers but I can't seem to find the guide on the 2.0. How many pipes are there? I've cleaned the one from the cover to the air intake and replaced the smaller one beside it. Are there any more that will need looking at? I've also cleaned around the butterfly with carb cleaner but it's still the same. Any further advice please?

6
Omega General Help / Noisy aircon pump
« on: 31 March 2007, 16:35:09 »
The aircon pump on my omega 2.0 gls auto became very noisy yesterday and I was hoping to get around it temporarily by fitting a new belt and bypassing the pump. The mechanic ordered a belt for a non aircon model but it was the wrong size. Has anyone fitted a smaller belt and if so what size?
Thanks.

7
Newbie Welcome Area / New member - new owner!
« on: 29 March 2007, 12:37:43 »
Hi all, Just thought I'd say hello and thank you for a brilliant forum. I've found out loads of info already by reading the previous posts.
Just got my 1st Omega. It's a 1997 'P' 2.0 GLS Auto saloon. I did a straight swap with one of my sons friends for a 1996 Pug 106 1.5D. Good swap I recon. He was fed up with putting fuel in the Omega as he has to drive around during the day for his job and I was fed up with shoe-horning myself into the 106 (I'm 6ft 2).
The Omega is pretty tidy, but has the knocking when going over bumps and the rising revs on tickover problem. I am hoping to get the wishbones checked in the next couple of days and clear out the breathers (could someone give me a clue where they are?!).
On the plus side there is a lot of recent main dealer service history with the car. The cambelt was changed at 82,000. The car has now covered 106,000. How ofter should the cambelt be changed?
I am loving driving the car, I'd forgotten how nice these big Vauxhalls are. I would have preferred a 3.0 Elite but beggars can't be choosers!

Pages: [1]

Page created in 0.127 seconds with 18 queries.