Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  


Search the maintenance guides for answers to 99.999% of Omega questions

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - pauls

Pages: [1] 2 3 4 5 6 7 8 ... 32
General Car Chat / Bmw x3
« on: 19 March 2018, 20:04:32 »
Had a look at a 2004 bmw x3 when you slow down you stop then you get a slight thump from the back. Chap told me it was because he has just put on 2 cheap tyres on the back. His  mechanic agreed with. I have googled it and it does seem to be a problem if same tyres are not the same make on all 4 wheels. Just thought i would ask your opinions on this. Yes i can walk away but would just like to know.

General Car Chat / p0171
« on: 06 March 2018, 19:17:04 »
This has come up on my audi 1.8t petrol. Car still runs great. I have done a bit of googling and it came back with maf,air leak,02 sensor.
 I cant see any split hoses.
would it be just a coinsidence that iam on my second tank of esso 98 oc really cold weather.
How do i check maf..
Code reader said it was lean on bank 1. Would this be the 02 sensor before cat.
can i keep running the car until i can fix the problem
Thanks for any help iam a bit stuck down here for help..

General Car Chat / 4x4
« on: 02 March 2018, 14:27:52 »
Knowning nothing really about this but after reading some stuff on here about bmw x5s and seening a land rover and a truck thing go up our hill without a problem but a chap in a range rover couldnt. My question is whats the best and why or is it just tyre choice and driver skill. Would lets say a audi quattro on winter tyres be as good as lets say a land rover. Also whats the difference in all wheel drive and a 4x4.

General Car Chat / Bmw run flat tyres
« on: 03 February 2018, 17:20:47 »
On the older cars so outside of warrant. Do you still need to use run flats.
Also anybody got any pro and cons on a 2008 320 petrol. Auto

General Car Chat / Headlight aim
« on: 01 February 2018, 14:09:40 »
Can you adjust the beam left or right as my passenger one seems to be aiming to far over to the right.

General Car Chat / Audi a4 estate radio
« on: 10 January 2018, 21:43:20 »
My audi radio keeps dropping its fm radio station. It wont even hold radio 2. The aerial is in the rear window. I have cleaned window but didnt help.
Would it be a idea to replace the aerial for one on the roof. I have read it has a seperate amp for the aerial would it help to change this. Any ideas please.

General Car Chat / explain please.
« on: 17 December 2017, 20:01:59 »
I run a 2004 1.8 turbo with a cvt box. Now i cannot seem to get the claimed 190hp out of it for example go to over take and it just  does not pickup it just seems to gain speed. My old 2.6 omega with same hp or less still picked up a lot better from say 40mph upwards.
The car is fully serviced and has no issues, so could somebody who drives or has driven a petrol turbo car explain to me the best way of using the engine/turbo. The gear box is cvt which i know means it doesnt have gears as such. I now drive a lot of A roads here in somerset and the bloody tractors are doing my head in >:(

General Car Chat / headlights
« on: 21 October 2017, 12:49:25 »

Can anybody help please Iam trying to find a replacement lense (dome Glass).

On the linked picture its the middle lense that i need. mine are cloudy and all though i have put the high out put osrams in its still not that bright.
Any help or links would be helpful as i have spent all morning trying to find them.

P.s these are not xenon.

General Car Chat / couple of questions
« on: 17 October 2017, 20:38:39 »
Audi 1.8 turbo petrol. I bought this back in april and the guy said it drinks a bit of oil. Since may i have been in somerset and my daily commute is 48 miles round trip  over 2 a roads. Over the summer i think i topped the oil up once but over the last several weeks the warning light has come on saying min oil. The first time i put about 3/4 of a litre in which had it half way up the dipstick. Today the light came on again so i topped it up to max on the dipstick.

question 1. How far could i safely travel when the light comes on.
question 2. It is standard for a petrol turbo to burn this much oil.

I couldnt see any oil leaks also isnt smokey when you hit the loud peddle.

General Discussion Area / Gamers
« on: 12 August 2017, 14:18:59 »
Any gamers on here. Just been to butlins with the family and my 9 year old who is mad about jurrasic park found a jurassic park shooting arcade game. I spent a bloody fortune on it. My question is. Is they a console first shooter game out they that he will get as much fun out of it. I have seen the lego one but he doesnt like that one. As its his birthday soon i thought i would try and find him something the same. Any help would be a help as i havnt a clue.

General Discussion Area / brick hole saw
« on: 17 June 2017, 20:03:37 »
I need to drill a couple of 125mm holes thru the outside wall. I can see a load of different ones on ebay etc but no idea what is the best. Anybody used one or recommend one. Cheers

General Car Chat / audi a4 3ltr tdi
« on: 11 June 2017, 21:06:13 »
Looking at buying one anything i should look out for ..are the 3ltr engines anygood. Does the quatro system cause issues.


General Car Chat / weird noise
« on: 21 May 2017, 17:06:48 »
On my 2004 audi 1.8t. It drives and runs great no oil usage but when i turn it off it sounds like a jet turbine powering down. I have had a look on the internet i cant find anything. I have read a few threads on start up being noisy but none on shut down. Any ideas please before i bend over at the local audi dealers.

General Car Chat / Audi a4 1.8 sline
« on: 15 May 2017, 17:02:05 »
Iam now running around in the audi now and it needs new discs and pads. Local dealer isnt that helpful so i was wondering if somebody could help on whats the best discs and pads for both front and back.

General Car Chat / rear parking sensors
« on: 29 March 2017, 18:19:11 »
I dont know if this is just a coincidence but yesturday i touched up the paint on my parking sensors and today now they are not working  :(.
 I just get a constant tone, i tried the quick omega test turning the ign on then car in reverse and checking each sensor for a clicking feel. I got nothing but if i tap each sensor the tone changes to  tapping tone.
 Can you put to much paint on..

They where all working in the terms of put car into reverse and it blipped once the bleep gets faster when you got closer to something

Pages: [1] 2 3 4 5 6 7 8 ... 32

Page created in 0.148 seconds with 18 queries.