Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - danzigfan

Pages: [1] 2 3 4 5 6 7 8 ... 84
1
Omega General Help / Re: Alloy cam covers
« on: 08 June 2018, 06:04:17 »
 :y Thanks

2
Omega General Help / Re: Alloy cam covers
« on: 07 June 2018, 06:42:20 »
I have 3 sets of plastic cam covers. Replaced them numerous times and only one  passenger side cover is straight enough to make a good seal. All others have warped outer edge and wouldn't seal properly even with GM gasket. There's always a leak somewhere. The solution would be a new unused set of plastic straight covers which are expensive like they're made of gold or simply a set of alloy ones. Breather and vacuum hoses  are clean as new

3
Omega General Help / Re: Alloy cam covers
« on: 06 June 2018, 18:47:06 »
I'm an idiot...posting it in Omega gallery >:( I'm sorry  :-\

4
Omega General Help / Alloy cam covers
« on: 06 June 2018, 18:44:53 »
Can't get those anywhere. I'm planning to repair rusty rear panels  this month followed by cambelt change and everything that goes with it, oil cooler too....I'll see if I'll replace leaking AC compressor ....long story short - if anyone has Veccy's  alloy cam covers just laying around for affordable price it would be the right moment to change them while I have it all appart.
TID Stan

6
Omega General Help / Re: Another air con question
« on: 01 June 2018, 13:40:22 »
I'm uploading video now, will post a link when it's done. Flap opens when AC setting on high, closes when setting is on low so no problem there it seems. I reset aircon, pressed "A" button a few times, still blowing cool not cold

7
Omega General Help / Re: Another air con question
« on: 01 June 2018, 12:40:41 »
And yet another question...Recirculating flap behind the pollen filter is closed...When does it open? How to check if it works? Could failed flap couse me air con problems like i have?

8
Omega General Help / Re: Another air con question
« on: 01 June 2018, 10:32:52 »
Done with cleaning the condenser, it made no difference so no result there. Interesting thing is that (UK side) passenger side of condenser stays hot all the time and driver side is just cold. Also that widened part of AC which is above oil dipstick is warm. I remember that part was freezing cold on previous Omega. Fans work, compressor kicks in I also removed pollen filter but it made no difference...I don't know what would be the problem here  :'(

9
Omega General Help / Re: Another air con question
« on: 31 May 2018, 21:02:50 »
https://youtu.be/a8qoFbwIS8M

Pollen filter is 6 months old and still clean, I checked it today...I hope link above works....might be one of the causes

10
Omega General Help / Another air con question
« on: 31 May 2018, 20:46:51 »
Hi guys, my air con never worked as it should - at least when I compare it to my previous MFL... Regased it last year - a little improvement shown but not as it should. Today I went to work and all I got from vents was slightly cold air.
Concidering that system has no leak, compressor kicks in, everything mechanicaly works as it should , would it make any difference if I clean/wash condenser? It could be full of all sort of things since it sits in front and maybe just can't work as it's supposed to.
Any thoughts about this?
TID Stan

11
Omega General Help / Re: Omega Repair Panels
« on: 16 May 2018, 14:16:37 »
https://m.ebay.de/itm/Opel-Omega-B-Bj-94-03-Radlauf-hinten-rechts-4Turer/253598999791?hash=item3b0bada4ef:g:lwAAAOSwVFlT7aNr

I need to buy this and the other side...plus 400 for labor. I hope it will help it live a few years more

12
General Car Chat / Re: Another cup holder solution
« on: 28 April 2018, 10:38:54 »
I saw your thread, that was nice too. I'm using coin box for parking card. Looks much better this way than it was before, with a adapter that only had a hole under the radio

13
General Car Chat / Re: Another cup holder solution
« on: 27 April 2018, 19:26:18 »
I obviously had too much time on my hands so I did this  ;)

https://s20.postimg.cc/57xebcyrh/IMAG1433.jpg

https://s20.postimg.cc/a6kwpwaa5/IMAG1436.jpg

https://s20.postimg.cc/64umswvjx/IMAG1439.jpg

https://s20.postimg.cc/4ielz48jh/IMAG1435.jpg

https://s20.postimg.cc/820jovt8t/IMAG1434.jpg

Can't find a way to paste pics directly
, I'm really sorry.
I found this item on ebay for 10, ordered 2 din mounting frame, painted it black and made a frame around radio and cup holder from plywood leftovers which had to be cut, sanded, primered and spray coloured black.
As you can see cup holder is a bit to near to shift knob but isn't touching it

http://www.omegaowners.com/forum/index.php?topic=137219.0

I know... But it's very hard to find a "ctrl" on keyboard when I'm using a phone :P

14
General Car Chat / Another cup holder solution
« on: 27 April 2018, 17:23:38 »
I obviously had too much time on my hands so I did this  ;)

https://s20.postimg.cc/57xebcyrh/IMAG1433.jpg

https://s20.postimg.cc/a6kwpwaa5/IMAG1436.jpg

https://s20.postimg.cc/64umswvjx/IMAG1439.jpg

https://s20.postimg.cc/4ielz48jh/IMAG1435.jpg

https://s20.postimg.cc/820jovt8t/IMAG1434.jpg

Can't find a way to paste pics directly, I'm really sorry.
I found this item on ebay for 10, ordered 2 din mounting frame, painted it black and made a frame around radio and cup holder from plywood leftovers which had to be cut, sanded, primered and spray coloured black.
As you can see cup holder is a bit to near to shift knob but isn't touching it

15
Omega General Help / Re: Airbags self deployment
« on: 21 April 2018, 10:32:06 »
It hapened to me few years back on my 2.0 estate...Just leaned the door on first click and went upstairs. Side airbag deployed when I got back.

Pages: [1] 2 3 4 5 6 7 8 ... 84

Page created in 0.129 seconds with 20 queries.