Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - danzigfan

Pages: 1 2 3 4 5 6 [7] 8 9 10 11 12 13 14 ... 84
91
Omega General Help / Re: Urgent ABS ECU connector removal
« on: 17 July 2017, 18:15:45 »
Fount it!  :y It's on the right side and pulls to the wheel arch...thanks guys
And I'm off to put a bag of coins into my swear box  :-X 


92
Omega General Help / Re: Urgent ABS ECU connector removal
« on: 17 July 2017, 17:58:46 »
There was to much of cam cover leak for to long to find even a trace of purple  on it... :-X :D
I'll try anyway, thanks :y

93
Omega General Help / Re: Urgent ABS ECU connector removal
« on: 17 July 2017, 17:42:12 »

94
Omega General Help / Urgent ABS ECU connector removal
« on: 17 July 2017, 17:41:42 »
Hi guys, I'm in the middle of this "nice afternoon job".....not >:( and I wonder how the h..l do I remove abs ecu connector from the unit?
I don't want to force it...there has to be a way.
I'd be happy if someone can help me.
TID Stan

95
General Car Chat / Re: Side mirror question
« on: 05 July 2017, 17:29:32 »
Thanks TB, I thought so

96
General Car Chat / Side mirror question
« on: 05 July 2017, 17:15:32 »
Hi guys, almost had a crash today, but managed to escape with driver side mirror glass broken only (blo..y Italian old lady >:( )  Searching trough Ebay, all the mirrors are listed as estate or saloon... I forgot,  is there a difference between those at all?
And if someone has one laying around...I'd really need one for a reasonable price - UK passenger side heated mirror glass with mounting.
Thanks

97
General Car Chat / Another Omega review
« on: 07 June 2017, 20:50:37 »
https://youtu.be/OXBTOVc6SJM

I hope this one hasn't been posted yet. That bloke was clearly pleasantly surprised

98
Omega General Help / Re: Poor air con performance
« on: 19 May 2017, 11:47:55 »
Regased it today, everything works fine. Thanks for your help :y

99
Omega General Help / Re: Poor air con performance
« on: 17 May 2017, 20:10:38 »
It was regased two and a half  years ago when I bought it and it had leaking "refiling" valve. BUT the price for regas was just 25...compared to usual 70 price where I live so...who knows what was it regassed with :-X...My fault I know

100
Omega General Help / Re: Poor air con performance
« on: 17 May 2017, 18:55:18 »
Tommorow's job.  I hope this works. Thanks guys :y

101
Omega General Help / Re: Poor air con performance
« on: 17 May 2017, 18:37:22 »


The part I'm holding on the pic should be cold,  but it's the same temperature as the exit pipe - luke warm

102
Omega General Help / Re: Poor air con performance
« on: 17 May 2017, 18:29:16 »
Going to check this now, thanks :y

103
Omega General Help / Re: Poor air con performance
« on: 17 May 2017, 16:09:10 »
I checked and compressor kicks in (rotates) when AUTO is pressed. Dissengages - stops when ECO is pressed.

104
Omega General Help / Re: Poor air con performance
« on: 17 May 2017, 14:22:23 »
I will, in an hour, I'm on the train now :y

105
Omega General Help / Re: Poor air con performance
« on: 17 May 2017, 03:31:24 »
Revs are around 550 so I believe compressor kicks in every time, Webby

Pages: 1 2 3 4 5 6 [7] 8 9 10 11 12 13 14 ... 84

Page created in 0.123 seconds with 19 queries.