Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - neil74

Pages: [1] 2 3 4 5 6 7 8 ... 24
1
Despite trying to avoid yet another pratt on the road he still managed to drive away again just like the last prick after stuffing the nearside wing in. so now i have yet more bloody work to do.

2
General Car Chat / Re: Nice mod?
« on: 24 April 2019, 18:05:22 »
Mine doesn't do that off the key. but when you open it remember to move your face out of the way because it will slap you under the chin thanks to the new struts I put on it.

3
General Car Chat / Re: How many have you owned..
« on: 24 April 2019, 18:02:07 »
The 1st was a 2.6 CDX saloon in silver in which the engine died. 2nd was a 2.5 elite saloon also silver which was written off by a Frenchman in a rental mokka. 3rd was a 2.2 manual GLS estate in nocturno blue which I sold to a banger racer unfortunately. 4th was a 3.2 elite estate in nocturno blue which was vandalised by druggies several times but now lives in Bristol. 5th was a 2.5 elite estate in a weird sort of reddish brown which was sold to someone who probably dismantled it or raced it. and the current one is familiar to several people on here too and which has been hit by an Asian in a Vectra who drove off and as also had one of the doors kicked in (druggies again). but is now ok again.

4
General Car Chat / Re: Low Mileage 3.2 MV6 on eBay
« on: 17 April 2019, 22:59:20 »
That's a nice colour. but i wonder just how much rot there is in those chassis rails..

5
Omega General Help / Re: Oil Leak
« on: 17 April 2019, 22:57:31 »
The plug wells on mine were full of oil on the offside and the nearside had some water too. due to the fact the plugs hadn't been touched for quite a while before I bought it if I had not bothered to check when I did I doubt that one of the plugs would have been able to be removed before much longer due to the rotten state of it.

6
Car Parts, bits For Sale & Wanted / Glovebox handle wanted.
« on: 13 April 2019, 20:55:31 »
I don't suppose anyone has a glovebox handle in beige or whatever the colour it might be for my car as it finally gave up yesterday and now I cant even close the thing up at all.

Cheers
Neil.

7
General Car Chat / Re: So what have you done to your car today?
« on: 13 April 2019, 16:04:00 »
Changed the oil and filter and smashed my thumb on the idler. and then opened the glovebox and had the handle fall off completely and now I cant even close the thing..

8
General Car Chat / Re: So what have you done to your car today?
« on: 11 April 2019, 23:37:03 »
Hopefully stopped the coolant leak and topped up with antifreeze. and despite my testing the alarm horn out of the car and finding it working it never did work again when I put it back on the car. so in went another horn I've had for years and when I deliberately set the alarm off it tooted like it should so im happy. just the oil/air/fuel filters to sort now with a couple of other items and it should keep going for a bit longer with any luck..

9
Omega General Help / Re: Idling problem.
« on: 06 April 2019, 14:45:19 »
In my worn out state I never noticed that one of the o rings that seals the plenum to the intake had fallen out hence the leak. but luckily it was still sitting on the airbox waiting for me to pop it back in. and I also cleared the fault code again.


Thanks
Neil.

10
Omega Electrical and Audio Help / Re: power sounder
« on: 04 April 2019, 15:15:50 »
The power sounder on my car had been removed before I bought it. but the horn that sits next to it used to work when you opened the door with the key after you had locked it with the remote but now only the hazards flash?.

11
Omega General Help / Idling problem.
« on: 03 April 2019, 22:25:52 »
Hello all,  Well after having done the cam cover seals and plugs the other day the engine has started to idle slightly faster than it normally does. and also when revved up has a tendency to stick at 2000-3000 rpm until I really rev it when it will eventually settle down to the slightly fast idle. im sure I put it all together properly and have gone around checking all the pipes and making sure everything is tightened correctly but it still continues to do the same thing. and today I have had the engine light illuminate and when I checked for codes I got the P0173 came up on the reader and which I deleted but which will probably come back again. can anyone shed some light on what the problem or problems might be..


Thanks
Neil.

12
General Car Chat / Re: So what have you done to your car today?
« on: 02 April 2019, 00:12:59 »
Changed the cam cover seals and spark plugs and what a messy pig of a job that was. and with any luck it might not leak..

13
Car Parts, bits For Sale & Wanted / Re: Heater hoses wanted.
« on: 22 March 2019, 20:57:54 »
Okey doke will try that. cant see it being fun though given what little space there is in there..

14
General Discussion Area / Re: Haynes Manual.
« on: 21 March 2019, 12:32:04 »
Its a pity they never printed an updated one for the facelift cars etc. I realise there's not a lot of difference with the later cars but it would have been handy to have..

15
Car Parts, bits For Sale & Wanted / Re: Heater hoses wanted.
« on: 21 March 2019, 12:26:57 »
Does anyone have or know where I can get these asap because I don't want the engine cooking itself if all the coolant escapes..

Thanks
Neil.

Pages: [1] 2 3 4 5 6 7 8 ... 24

Page created in 0.119 seconds with 19 queries.