Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please play nicely.  No one wants to listen/read a keyboard warriors rants....

Pages: [1]   Go Down

Author Topic: Omrga starting problems  (Read 736 times)

0 Members and 1 Guest are viewing this topic.

0mega2.5

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Gloucester
  • Posts: 3
    • vauxhall carlton 3 litre
    • View Profile
Omrga starting problems
« on: 13 May 2014, 12:27:55 »

Hi all, I have an Omega Elite estate, when I bought it it was flattening the battery, the day after getting it home battery was flat, so I jump stated it off my Carlton, it was an instant start which was satisfying, I discovered on turning it off that the computer was staying on, so decided to disconnect the battery, this is when I noticed with ignition turned off that there was quite a large flash at the battery terminal, on reconnecting the battery all appeared well with the computer turning off after the ignition was turned off,  but strangely the car will not start straight away. it appears that the glow plugs are not working, can anyone tell me which relay controls the Glow plugs as I am wondering if the relay was at fault and was causing the battery drain, any advice would be appreciated,
Logged

sandune

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Essex Southend
  • Posts: 2404
    • 2.6 Omega Auto
    • View Profile
Re: Omrga starting problems
« Reply #1 on: 13 May 2014, 18:10:18 »

Hiya welcome,to receive the answers you're after it's better to post in the "General Help" section,as this is where the boffins usually are :y
Logged

omega3000

  • Guest
Re: Omrga starting problems
« Reply #2 on: 13 May 2014, 19:48:39 »

Welcome to oof  :y
Logged

Figureman52

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Nottingham
  • Posts: 375
    • 2.6 CD Saloon
    • View Profile
Re: Omrga starting problems
« Reply #3 on: 13 May 2014, 20:39:48 »

Hello and Welcome. :y
Logged

badmuver

  • Guest
Re: Omrga starting problems
« Reply #4 on: 13 May 2014, 20:55:54 »

Welcome to the forum  :y
Logged

flyer 0712

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Posts: 2713
    • View Profile
Re: Omrga starting problems
« Reply #5 on: 13 May 2014, 21:09:02 »

Hi and welcome  :y
Logged

Cliffo B

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Leeds West Yorkshire
  • Posts: 3826
    • 03 3.2 Elite Estate
    • View Profile
Re: Omrga starting problems
« Reply #6 on: 13 May 2014, 22:07:24 »

Hello,welcome to the Forum :y
Logged

Johnny English

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Hungary
  • Posts: 2050
  • English antitalent
    • 1995. 2.5 V6 LPG manual
    • View Profile
Re: Omrga starting problems
« Reply #7 on: 14 May 2014, 11:02:16 »

Welcome to oof mate!  :)
Logged
C20NE - X25XE

x25dt

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Male
  • Portugal
  • Posts: 1648
    • View Profile
Re: Omrga starting problems
« Reply #8 on: 15 May 2014, 18:05:01 »

welcome to the forum.  :y
Logged

dbug

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Northants
  • Posts: 14279
  • Dont knock Linux!
    • Jaguar XJ 5.0V8 Portfolio
    • View Profile
    • Dbug IT Services
Re: Omrga starting problems
« Reply #9 on: 16 May 2014, 22:22:24 »

Welcome to OOF mate :y
Logged
1972 Ferrari Dino, 1967 Triumph TR4A, Mondeo 2.0TDCi Estate, Jaguar XJ 5.0V8 Portfolio
Pages: [1]   Go Up
 

Page created in 0.211 seconds with 21 queries.