Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to OOF

Pages: [1]   Go Down

Author Topic: Faulty Knock sensors ???  (Read 561 times)

0 Members and 1 Guest are viewing this topic.

Elmstoneboy

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • Biddenden Kent UK
  • Posts: 75
    • J reg 2.6 V6 Auto CDX
    • View Profile
Faulty Knock sensors ???
« on: 31 July 2014, 00:17:44 »


What's the symptoms of faulty knock sensors? Can you hear the engine knocking (we used to call it pinking). As I have mentioned in a previous post I occasionally get what sounds like a quiet diesel rattle, but only when accelerating, and nothing when stationary and just revving engine. It also feels like it may be down a bit on power. Sometimes engine runs really quite and purrs, especially at the moment when the weather is hot. Checked leads for damage but they seem alright and not trapped. Is there anything else that could cause similar symptoms?  MAF maybe?       I am not getting any fault codes.
Logged

Temetsy

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • Finland
  • Posts: 211
    • b1 x25xe sedan
    • View Profile
Re: Faulty Knock sensors ???
« Reply #1 on: 31 July 2014, 00:49:09 »

Leaking/cracked exhaust manifolds. Never heard a v6 knock sensor gone bad (the sensor itself, wires can be broken due to careless placement). Does the sound appear only when running cold/hot?
Logged

chrisgixer

  • Guest
Re: Faulty Knock sensors ???
« Reply #2 on: 31 July 2014, 05:54:16 »

Rarely hear about knock sensors on omega unless the cable has been trapped during cam cover re fitting.
Logged

Elmstoneboy

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • Biddenden Kent UK
  • Posts: 75
    • J reg 2.6 V6 Auto CDX
    • View Profile
Re: Faulty Knock sensors ???
« Reply #3 on: 31 July 2014, 09:40:35 »


Leaking/cracked exhaust manifolds. Never heard a v6 knock sensor gone bad (the sensor itself, wires can be broken due to careless placement). Does the sound appear only when running cold/hot?

Engine temp doesn't appear to make a difference, but air temp does. Nice hot humid day and it purrs. Some days it runs quiet,
but then you pull up at a junction and when you pull away the rumble is back, but only when accelerating. Cruising is always quiet.
Pretty sure it's nothing cracked or leaking, not that sort of sound, and 99.9% sure it's nothing mechanical as you can rev it when stationary without any rumbles or rattles. Cables look OK, down as far as I can see them. I,ll have to get underneath and have a look at the bottom end of the cables.  I wondered about the MAF as knocking can also be caused by the fuel air mix, but the
sensor should adjust for that.
Forgot to mention it's only done 61,000, so still all nice and clean.

Pretty sure it's northing serious, but it's a noise that I notice and would like to stop.
Logged

Temetsy

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • Finland
  • Posts: 211
    • b1 x25xe sedan
    • View Profile
Re: Faulty Knock sensors ???
« Reply #4 on: 31 July 2014, 09:53:53 »

The sound of cracked/leaking exhaust manifold can be very deceiving, mine leaked and i was damm sure it was the hydros or engine knocking since the sound was really metallic but no, twisted exhaust manifold was leaking :y
Logged

Johnny English

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Hungary
  • Posts: 2050
  • English antitalent
    • 1995. 2.5 V6 LPG manual
    • View Profile
Re: Faulty Knock sensors ???
« Reply #5 on: 31 July 2014, 15:50:12 »

A week ago I managed to sort my knock cable fault out, couldn't hear knocking at all but felt hesitation during accelerating. Plus faulty knock sensor always gives code, if not then it works properly. ;)

Good luck mate!  :y

Laszlo
Logged
C20NE - X25XE

tooleater

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • Rickmansworth,  Herts
  • Posts: 526
    • Go faster Black MV6 Man
    • View Profile
Re: Faulty Knock sensors ???
« Reply #6 on: 01 August 2014, 18:10:26 »

Mine is doing something similar, except I can just hear a very light Pinking if say I changed From 2nd into 3rd and I will have to strain my ears to hear it, but recently it has developed a very occasional misfire and feels like there is a delay in power, but again not all the time, interesting comment about exhaust though : I just drive Like miss Daisy until something shows or gives up the ghost ;D
Logged

Elmstoneboy

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • Biddenden Kent UK
  • Posts: 75
    • J reg 2.6 V6 Auto CDX
    • View Profile
Re: Faulty Knock sensors ???
« Reply #7 on: 02 August 2014, 12:10:37 »




Thanks all, for your thoughts, guess I will just have to turn up the radio until something comes along.
Logged
Pages: [1]   Go Up
 

Page created in 0.143 seconds with 23 queries.