Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: 1 [2]  All   Go Down

Author Topic: any tv engineers here please  (Read 776 times)

0 Members and 1 Guest are viewing this topic.

TheBoy

  • Administrator
  • *********
  • Offline Offline
  • Gender: Male
  • Brackley, Northants
  • Posts: 96396
  • Millennium Man
    • Anything that goes
    • View Profile
Re: any tv engineers here please
« Reply #15 on: 10 March 2018, 08:48:32 »

I thought our shitty Grundig badged PoS in the kitchen was suffering a cap problem, when most times it was turned on, as soon as it turned on the panel's backlight, it would shut down and repeat, until eventually it would start.

Not really being a fan of the thing anyway (and CBA issues), I was all for replacing it...   ...until I found I couldn't get one small enough to fit. Which is why we ended up with this crappy thing 7 or 8 years ago.

*SIGH*, so last weekend I HAD to have a look.

Imagine my delight when I pull the TV out, and see its an external PSU...   ...and even better, there is a bit of corrosion built up on the power plug.  Quick clean up, jobs a good'un.


Its still a PoS, takes 30s for the DTV tuner to boot, piss poor view angle. But a working PoS ;D
Logged
I don't tolerate bickering, and I'm always grumpy.
And Lizzie Zoom says I'm a heartless bastid...and she's absolutely correct!

cam.in.head

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • West yorkshire
  • Posts: 540
    • omega cdx 2.6 auto
    • View Profile
Re: any tv engineers here please
« Reply #16 on: 10 March 2018, 14:19:27 »

hi just one more thing(columbo has left the building)
i have just picked up a txp50x50 for parts (broken screen ) and the power supply in this is almost identical albeit a few layout changes and some components.
this power supply works fine on the bench so i could use it to fix my other dependant on bits or would it actually work in the txp50xt50 ?
or ! would it work if i swapped it as a unit with the main control board too .the rest of the panels have the same part numbers and i beleive the x version just didnt have smart tv ? whereas the xt is smart
Logged

cam.in.head

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • West yorkshire
  • Posts: 540
    • omega cdx 2.6 auto
    • View Profile
Re: any tv engineers here please
« Reply #17 on: 13 March 2018, 17:41:06 »

spoke to a couple of tv shops near me who say the x board will be fine in the xt so will fit it and see. now on with the dreaded tnpa4782 board from a pg ..thanks for help and advice.
Logged

cam.in.head

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • West yorkshire
  • Posts: 540
    • omega cdx 2.6 auto
    • View Profile
Re: any tv engineers here please
« Reply #18 on: 18 March 2018, 17:15:57 »

4782 board has many many shorts as i was expecting. Replaced all found transistors and a couple of diodes that were shorted.missed something thou as the board popped upon powering and one transistor shorted again.there was a very small flash but cannot see where it came from as it was too quick.three of my local shops wont touch the board and have advised looking for another but they are hard to come by and seem expensive when they do.
Anyone got one .its a tnpa4782ab from a tx-p50g10b.i may just replace the two buffer boards too to be sure but they are cheap enough and available.
So now that the other tv with the darfon b159-201 board is up and running im gonna have a look again at the old board and see if i can get it going as a spare. Ive replaced the 6755 chip twice but its still not firing up.no 5v stby.
Silly novice question. Does the vdd voltage get generated inside the chip and then sustained by the transformer or is it fed externally from over the other side of the board from the transistor next to the optocoipler. There is 5v over there going into one side of this transistor ref main cap negative. .
Logged

Kevin Wood

  • Global Moderator
  • *****
  • Offline Offline
  • Gender: Male
  • Alton, Hampshire
  • Posts: 34115
    • 3.2 MV6 (LPG), Westfield
    • View Profile
Re: any tv engineers here please
« Reply #19 on: 18 March 2018, 20:03:41 »

4782 board has many many shorts as i was expecting. Replaced all found transistors and a couple of diodes that were shorted.missed something thou as the board popped upon powering and one transistor shorted again.there was a very small flash but cannot see where it came from as it was too quick.three of my local shops wont touch the board and have advised looking for another but they are hard to come by and seem expensive when they do.
Anyone got one .its a tnpa4782ab from a tx-p50g10b.i may just replace the two buffer boards too to be sure but they are cheap enough and available.
So now that the other tv with the darfon b159-201 board is up and running im gonna have a look again at the old board and see if i can get it going as a spare. Ive replaced the 6755 chip twice but its still not firing up.no 5v stby.
Silly novice question. Does the vdd voltage get generated inside the chip and then sustained by the transformer or is it fed externally from over the other side of the board from the transistor next to the optocoipler. There is 5v over there going into one side of this transistor ref main cap negative. .

Sounds like you need to make yourself a dim bulb tester. ;)
Logged
Tech2 services currently available. See TheBoy's price list: http://theboy.omegaowners.com/

cam.in.head

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • West yorkshire
  • Posts: 540
    • omega cdx 2.6 auto
    • View Profile
Re: any tv engineers here please
« Reply #20 on: 19 March 2018, 17:42:37 »

yeah its ok through that via a 60w and a 100w but popped on straight through.there are so may items thst these bosrds that can cascade apparently that many shops dont want to touch it and just like to swap boards which i will probably end up doing too.
back to the other board thou.the fan 6755 chip isnt getting any voltage at all to pin 6 vdd but im not sure if its genersted internally or supplied elsewhere as a kick start ?
ive replaced the smoothing cap and checked the two diodes for shorts.the other pins seem to be getting a supply where required so is it a faulty chip or somewhere else on the board.
other tv working fine so its only a spare board.
anyone local to west yorks have a board ( or any other panasonic plasma for throwing !)
Logged
Pages: 1 [2]  All   Go Up
 

Page created in 0.137 seconds with 21 queries.