Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: [1]   Go Down

Author Topic: Relay confusion  (Read 174 times)

0 Members and 1 Guest are viewing this topic.

BazaJT

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • SLady bitshorpe N.Lincs.
  • Posts: 6784
    • Omega 3 litre Elite
    • View Profile
Relay confusion
« on: 31 July 2019, 21:00:10 »

Quick investigation[hopefully more in depth tomorrow weather permitting] as to why the horn don't work on my Volvo 960 showed that the original horns have been replaced at some point by a 3 horn airhorn which has rusty terminals-which can't be helping matters-checked fuse anyway which is good but then it came to the relay.Schematic on underside of lid shows where/what for the relay positions are but not colour of relay,it also ascribes a letter to each relay[A,N J etc]but on the car all the relays apart from one at the very front of the box are black and all have the letter J on top.The one exception being yellow with no letter on it.Everything on the car works-apart from the horn of course but how do I tell if the horn relay is the correct one or if I can temporarily swap it over with one of the others to prove it's not a relay fault?
Logged

STEMO

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Up North
  • Posts: 13832
    • Astra 2.0 diesel
    • View Profile
Re: Relay confusion
« Reply #1 on: 31 July 2019, 21:01:31 »

Quick investigation[hopefully more in depth tomorrow weather permitting] as to why the horn don't work on my Volvo 960 showed that the original horns have been replaced at some point by a 3 horn airhorn which has rusty terminals-which can't be helping matters-checked fuse anyway which is good but then it came to the relay.Schematic on underside of lid shows where/what for the relay positions are but not colour of relay,it also ascribes a letter to each relay[A,N J etc]but on the car all the relays apart from one at the very front of the box are black and all have the letter J on top.The one exception being yellow with no letter on it.Everything on the car works-apart from the horn of course but how do I tell if the horn relay is the correct one or if I can temporarily swap it over with one of the others to prove it's not a relay fault?
You been pressing that S button again?  ;D
Logged
If you are offended by anything I post, sorry. Just thought I'd get that in now.

BazaJT

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • SLady bitshorpe N.Lincs.
  • Posts: 6784
    • Omega 3 litre Elite
    • View Profile
Re: Relay confusion
« Reply #2 on: 31 July 2019, 21:06:02 »

That's just the thing I've been nowhere near that damn icon >:( >:(
Logged
Pages: [1]   Go Up
 

Page created in 0.125 seconds with 21 queries.