Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Pages: [1]   Go Down

Author Topic: Poly bushes for the rear subframe on a Omega A 3.0!?  (Read 168 times)

0 Members and 1 Guest are viewing this topic.

Evo500omega

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Portugal
  • Posts: 13
    • Omega 3.0 24v
    • View Profile
Poly bushes for the rear subframe on a Omega A 3.0!?
« on: 01 September 2019, 18:31:30 »

Hello dear friends.

Can anyone knows we're a can order Poly bushes for the rear subframe of a Omega A 3.0??  :D

Thanks mates!!! 😁



Logged

Nick W

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • Chatham, Kent
  • Posts: 7407
  • Rover Metro 1.8VVC
    • 3.0l Elite estate
    • View Profile
Re: Poly bushes for the rear subframe on a Omega A 3.0!?
« Reply #1 on: 01 September 2019, 19:21:18 »

You can use Monaro ones for the subframe mounts if you're prepared to pay about four times as much as stock rubber ones. Honestly, you'll only ever need to change these bushes once, if at all. So unless you're a genuine F1 test driver it probably isn't worthwhile. The semi-trailing arm bushes never seem to fail, and stock new ones are cheap. Same applies to the anti-roll bar mounts.


I would suggest you buy new stock subframe bushes, and spend the difference on some new springs.
Logged

Enceladus

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 338
    • View Profile
Re: Poly bushes for the rear subframe on a Omega A 3.0!?
« Reply #2 on: 01 September 2019, 20:01:05 »

The usual fix for squeaking but otherwise functional Omega A/Carlton/Senator suspension bushes was a good squirt of silicone oil.
Logged

Evo500omega

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Portugal
  • Posts: 13
    • Omega 3.0 24v
    • View Profile
Re: Poly bushes for the rear subframe on a Omega A 3.0!?
« Reply #3 on: 02 September 2019, 11:57:36 »

Thanks mates, I'll buy the rubber ones...  ;D :D

They have a big break now... in acceleration they shake and make a knocking noise  :( :-X

Logged

Nick W

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • Chatham, Kent
  • Posts: 7407
  • Rover Metro 1.8VVC
    • 3.0l Elite estate
    • View Profile
Re: Poly bushes for the rear subframe on a Omega A 3.0!?
« Reply #4 on: 02 September 2019, 12:04:06 »

you should also inspect the differential mounts.


They have not been available for several years, so they have to be repaired rather than replaced. Like this:


Logged

Evo500omega

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Portugal
  • Posts: 13
    • Omega 3.0 24v
    • View Profile
Re: Poly bushes for the rear subframe on a Omega A 3.0!?
« Reply #5 on: 02 September 2019, 12:42:30 »

thanks NICK !!!  :D

latter I'll inspect the differential mounts.

They are repaired with liquid polyurethane?

Thanks  ;D
Logged

Nick W

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • Chatham, Kent
  • Posts: 7407
  • Rover Metro 1.8VVC
    • 3.0l Elite estate
    • View Profile
Re: Poly bushes for the rear subframe on a Omega A 3.0!?
« Reply #6 on: 02 September 2019, 12:50:18 »

thanks NICK !!!  :D

latter I'll inspect the differential mounts.

They are repaired with liquid polyurethane?

Thanks  ;D


Yes, they are.


I made the jig to do both mounts simultaneously to save time and material(you need about 250g of polyurethane to do both) and be reusable, but a one-off could be done with a few bits of plywood and glue.
Logged
Pages: [1]   Go Up
 

Page created in 0.108 seconds with 21 queries.