Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to OOF

Pages: 1 2 [All]   Go Down

Author Topic: car struggling to start on first start  (Read 587 times)

0 Members and 1 Guest are viewing this topic.

TraceyCassels

  • Newbie
  • *
  • Offline Offline
  • Gender: Female
  • southlanarkshire Scotland
  • Posts: 6
    • omega CD auto
    • View Profile
car struggling to start on first start
« on: 07 November 2019, 12:59:00 »

Car struggling to start on first start having to rev it to try and get it going once going its better but still running rough showing code PO170 and PO130 on code reader  just passed MOT  yesterday collected it only to bring it out garage to have same problem it went in with garage told me just run it  hard to run it when I have trouble starting it  owned car for 14 yrs  just had service done last month  its a 52 plate 106,438 milage  all garage round about me say scrap it , or run it the way it is why nobody wants to fix cars anymore is beyond me  in Southlanarkshire Scotland if anyone can help really don't want to give on car as it done me well for 14 yrs  had all brakes , handbrake , service and lots of little things done including underseal on car in the last 4 months so really want to keep car any advice help welcome
Logged

Doctor Gollum

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 14680
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: car struggling to start on first start
« Reply #1 on: 07 November 2019, 14:50:07 »

What engine?
Logged
Onanists always think outside the box.

Doctor Gollum

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 14680
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: car struggling to start on first start
« Reply #2 on: 07 November 2019, 15:10:13 »

Both codes are emissions related.

If it's a 2.0/2.2 then possible an exhaust issue either at the flexi pipe or the manifold ;)
Logged
Onanists always think outside the box.

TraceyCassels

  • Newbie
  • *
  • Offline Offline
  • Gender: Female
  • southlanarkshire Scotland
  • Posts: 6
    • omega CD auto
    • View Profile
Re: car struggling to start on first start
« Reply #3 on: 07 November 2019, 17:19:39 »

yes its a 2.2 petrol
Logged

Eboy.com

  • Administrator
  • *********
  • Offline Offline
  • Gender: Male
  • Brackley, Northants
  • Posts: 208
  • Bring back the starting handle
    • The missus mad
    • View Profile
Re: car struggling to start on first start
« Reply #4 on: 07 November 2019, 17:42:45 »

Ideally it needs some live data off it to see what its doing, but I think the 1st lamda is causing the mixture to go way off.

This could be a faulty lamda, potentially a faulty MAF, or an airleak before or after the engine.
Logged
I own a Zafira, I'm allowed to feel depressed.

Enceladus

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 419
    • View Profile
Re: car struggling to start on first start
« Reply #5 on: 07 November 2019, 18:46:34 »

The 2.2 engine is not some rarity unique to an Omega B. It was used in multiple of GM vehicles and even a Fiat. It's also an engine that is in essence a simple evolution of the four cylinder engines that preceded it. There are thousands on the road so it should be well within the capability of any competent independent to fix.

The faults refer to sensor one. The first one in the downpipe and visible from the engine bay. These sensors have a lifespan of around 100,000 miles. So you seem to have had the life out of it. The pre-cat in the downpipe might also be damaged due to old age. You'd be well served to get some live data from the diagnostic port, to see do you need a new front sensor or a cat downpipe and both sensors.

On my estate a big hole in the flexi caused a loud exhaust but didn't trigger any fault codes. When somebody replaced the downpipe and failed to plug the 1st lambda sensor into the connector properly it did, when the cable fell apart. On that basis your issue lies upstream of the flexi.
Logged

TraceyCassels

  • Newbie
  • *
  • Offline Offline
  • Gender: Female
  • southlanarkshire Scotland
  • Posts: 6
    • omega CD auto
    • View Profile
Re: car struggling to start on first start
« Reply #6 on: 07 November 2019, 19:27:09 »

thank you  just need someone willing to fix it which is causing more problems garages just don't seem to like working on omegas  anyone in Scotland  that could help
Logged

Diamond Black Geezer

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • N E Lincolnshire & Coventry
  • Posts: 5639
  • Diamond Black '96 CDX V6 - 'Pissy'
    • & a silly coupe coming...
    • View Profile
Re: car struggling to start on first start
« Reply #7 on: 07 November 2019, 19:56:44 »

Sorry I don't have any info for you , OP, sadly but as said above, the 2.2 was used on plenty of Vauxhalls - so not even a 'tricky' lump that some most garages wouldn't want the aggro of working on. It most definitely is worth saving, though, that's for sure!

Without sending you down a blind alley - I would add that just because the fault codes are showing emissions doesn't necessarily stand that is the problem, yes, there are emissions issues, but there could be other things, like lazy fuel pumps (had that this week  ::)). But ignore what I say for now, DG / TBB's info should be looked at first!  :y ;D

Welcome to the forum, by the way!
Logged
Ex-Dealer Kent-Moore Rear Wheel Bearing Tool available for hire, PM for details.

"There's no point in being grown up if you can't be childish sometimes." 4th Doctor

TraceyCassels

  • Newbie
  • *
  • Offline Offline
  • Gender: Female
  • southlanarkshire Scotland
  • Posts: 6
    • omega CD auto
    • View Profile
Re: car struggling to start on first start
« Reply #8 on: 07 November 2019, 20:02:55 »

thanks yeh love the car been part of the family for 14 yrs towed horse box with it years ago and been used daily last 14 years so angry with the way garages don't want to work on omegas  so pleased I came on here such friendly helpful people on here
Logged

sjc

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • Alloa, Scotland
  • Posts: 690
    • M5 ; 3.0 MV6 Manual
    • View Profile
Re: car struggling to start on first start
« Reply #9 on: 07 November 2019, 21:01:21 »

I know he's not particularly close to you but John @ MV Turbos in Kinross is not afraid of these kind of jobs.
Logged
If you Elite an MV6, does that make it an MVee-leet?

Andy H

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • Auckland
  • Posts: 5299
    • Mazda MPV
    • View Profile
Re: car struggling to start on first start
« Reply #10 on: 08 November 2019, 09:12:31 »

IIRC the 2,2 is the one that gets totally confuddled when the cam-sensor goes tits up  :-\

- probably not relevant though because there was no mention of gearbox codes
Logged
"Deja Moo - The feeling that you've heard this bull somewhere before."

Diamond Black Geezer

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • N E Lincolnshire & Coventry
  • Posts: 5639
  • Diamond Black '96 CDX V6 - 'Pissy'
    • & a silly coupe coming...
    • View Profile
Re: car struggling to start on first start
« Reply #11 on: 08 November 2019, 16:11:59 »

thanks yeh love the car been part of the family for 14 yrs towed horse box with it years ago and been used daily last 14 years so angry with the way garages don't want to work on omegas  so pleased I came on here such friendly helpful people on here

I don't think any of us even look in the Haynes manual very much at all, so much info is on here, and so readily the info is offered. 99% someone else has had the same problem, and a fix has been found. Hoping we get to the bottom of this soon - how 'handy' do you feel about working on cars?
Logged
Ex-Dealer Kent-Moore Rear Wheel Bearing Tool available for hire, PM for details.

"There's no point in being grown up if you can't be childish sometimes." 4th Doctor

The Pikey Pensioner

  • Administrator
  • *********
  • Offline Offline
  • Gender: Male
  • North Birmingham
  • Posts: 13247
  • Merc to annoy TB
    • MB C-class Estate
    • View Profile
Re: car struggling to start on first start
« Reply #12 on: 09 November 2019, 07:58:32 »

IIRC the 2,2 is the one that gets totally confuddled when the cam-sensor goes tits up  :-\

- probably not relevant though because there was no mention of gearbox codes

Sounds like cam sensor to me.
Logged
Merc lover

TraceyCassels

  • Newbie
  • *
  • Offline Offline
  • Gender: Female
  • southlanarkshire Scotland
  • Posts: 6
    • omega CD auto
    • View Profile
Re: car struggling to start on first start
« Reply #13 on: 11 November 2019, 09:28:25 »

Been to garage they say car is starved of fuel so its booked in to get looked at next week so fingers crossed
Logged

Doctor Gollum

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 14680
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: car struggling to start on first start
« Reply #14 on: 11 November 2019, 09:33:45 »

Saloon or estate?

If estate, make sure the car is level and has at least a quarter tank. If not add AT LEAST 2 gallons and try again.

If that doesn't work, slap the bottom of the tank whilst someone else tries to start it. (you can try this first as it's free, but might need to repeat after adding more fuel).

If it starts from adding more fuel, then that was your problem. If it starts from slapping the tank, then you need a new fuel pump.  :y
Logged
Onanists always think outside the box.

Diamond Black Geezer

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • N E Lincolnshire & Coventry
  • Posts: 5639
  • Diamond Black '96 CDX V6 - 'Pissy'
    • & a silly coupe coming...
    • View Profile
Re: car struggling to start on first start
« Reply #15 on: 11 November 2019, 10:24:22 »

This.

It's amazing how many things there are that are free fixes/diagnostics. And dont think for a second that many a garage won't do the same, sometimes it just helps diagnose the issue, but other times when it's something like a fuse (which I'm counting as a 'free fix') that's a nice few quid in the old Xmas fund for no effort. Leave the car there for a couple of hours to make it look like it took some effort "yeah you had an issue on your squared grommet, but we re-sponged it, which is normally 100 but did it for 50, luv"

So worth trying the free fixes/diagnostics first.  :y
Logged
Ex-Dealer Kent-Moore Rear Wheel Bearing Tool available for hire, PM for details.

"There's no point in being grown up if you can't be childish sometimes." 4th Doctor

TraceyCassels

  • Newbie
  • *
  • Offline Offline
  • Gender: Female
  • southlanarkshire Scotland
  • Posts: 6
    • omega CD auto
    • View Profile
Re: car struggling to start on first start
« Reply #16 on: 22 November 2019, 12:07:56 »

looks like throttle body is the problem with starting also coolent isn't giving the correct reading 
Logged
Pages: 1 2 [All]   Go Up
 

Page created in 0.156 seconds with 22 queries.