Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: 1 2 [All]   Go Down

Author Topic: Hi all In trouble already.  (Read 371 times)

0 Members and 1 Guest are viewing this topic.

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Hi all In trouble already.
« on: 02 December 2019, 18:20:57 »

Hi all im a new member so hi to you all.Ive just bought a 2001 2.6 auto mv6 and ive got problems already lol. First is that ive got no heat on the heaters and the thermostat is not moving.Second is that the orange car with the spanner has come up and when changing the auto box all the lights alongside the stick were lit up plus in drive it was slow acceleration.Is it toast already Thanks Gavin
Logged

Andy B

  • Get A Life!!
  • **********
  • Offline Offline
  • Gender: Male
  • Bury Lancs
  • Posts: 36856
    • R320 TDM850 SmartRoadster
    • View Profile
Re: Hi all In trouble already.
« Reply #1 on: 02 December 2019, 18:45:39 »

Hi Gavin
When you say the the 'thermostat' isn't moving I guess you mean the temp gauge  :-\ The temp gauge could be a missing wire from the temp sensor at the back of the engine http://www.omegaowners.com/forum/index.php?topic=113765.0
A stuck open thermostat will result in lack of heat at the heater  ;) http://www.omegaowners.com/forum/index.php?topic=90603.0 and http://www.omegaowners.com/forum/index.php?topic=90647.0

Sounds like your gearbox is stuck in 3rd

Can't remember if the engine light is the fault code light on your car or not, but this is how you read fault codes on your car http://www.omegaowners.com/forum/index.php?topic=90581.0
« Last Edit: 02 December 2019, 18:47:56 by Andy B »
Logged

Migv6 le Frog Fan

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • Webs End.
  • Posts: 6714
  • Nicole's Papa
    • 3.2 Elite & Welsh Hatch
    • View Profile
Re: Hi all In trouble already.
« Reply #2 on: 02 December 2019, 18:50:54 »

Sounds like it needs a thermostat change and gearbox selector switch cleaned. All perfectly doable diy if your reasonably handy with spanners.
Have a look in the maintenance guides section for info on the work involved in these jobs.
Logged
Plastic Welsh hatchbacks are awesome.

addy

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • West Cornforth, County Durham.† UK
  • Posts: 416
    • 2002 2.6 CD Saloon
    • View Profile
Re: Hi all In trouble already.
« Reply #3 on: 02 December 2019, 18:53:46 »

If i'm not mistaken doesn't all the lights lit up at same time, on gear selection display point to selector switch on side of gearbox being dirty? There used to be a how to in maintenance explaining the cleaning of it, but it is missing.

Spanner light on my 2002 2.6 means there is a error. Pedal trick didn't work on my 2.6. I had to burp the coolant system on my car as there was air in the system, preventing the heater getting hot inside the car. A coolant flush as in maintenance might help?

« Last Edit: 02 December 2019, 18:56:15 by addy »
Logged
Drives 1995 2.0ltr CD Estate.  2002 2.6 CD saloon

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #4 on: 02 December 2019, 19:00:56 »

Hi everyone thanks for the quick replys, ive had a 2.2 manual before but never an auto. On the way back all of a sudden all the lights lit up along the gear selector ie 1 2 3 D R it seemed slower to accelerate.So i guess that its a clean on the gear selector stuff under the stick.If the orange light is on does it go into limp mode.Thanks
Logged

Andy B

  • Get A Life!!
  • **********
  • Offline Offline
  • Gender: Male
  • Bury Lancs
  • Posts: 36856
    • R320 TDM850 SmartRoadster
    • View Profile
Re: Hi all In trouble already.
« Reply #5 on: 02 December 2019, 19:02:56 »

Hi everyone thanks for the quick replys, ive had a 2.2 manual before but never an auto. On the way back all of a sudden all the lights lit up along the gear selector ie 1 2 3 D R it seemed slower to accelerate.So i guess that its a clean on the gear selector stuff under the stick.If the orange light is on does it go into limp mode.Thanks

Not necessarily .... but if it's the selector switch that needs cleaning, your car will stick in 3rd
Logged

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #6 on: 02 December 2019, 19:27:05 »

Thanks mate ive just been outside, its freezing out there at the moment and checked the coolant level it seems fine nothing in it no oil etc.I will get the gear switch cleaned and get a new thermostat put in.At idle now there no orange spanner and sports mode can be selected from the stick again there no faults on the info screen other than cdc error.Will keep you updated and great to be part of such a great community again.
Logged

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #7 on: 02 December 2019, 19:45:13 »

If theres anyone in kent who wants to do the work i will pay cash, as i am working 7 days a week at the moment and it tough to find time to start working on it myself but i would be really thankful.
Logged

Doctor Gollum

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 14662
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: Hi all In trouble already.
« Reply #8 on: 02 December 2019, 20:43:27 »

Given your location, give NickW a shout :y
Logged
Onanists always think outside the box.

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #9 on: 02 December 2019, 20:50:09 »

Nice one mate Cheers
Logged

Entwood

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • North Wiltshire
  • Posts: 19140
  • My Old 3.2 V6 Elite (LPG)
    • Audi A6 Allroad 3.0 DTI
    • View Profile
Re: Hi all In trouble already.
« Reply #10 on: 02 December 2019, 21:00:13 »

Gear lights : As a temporary "fix", with the engine not running, cycle the gear selector thorough its whole range several times. Not a promise it will work, but sometimes it clears the tracks enough that it works properly for a short time. Needs a full proper clean however

:)
Logged
V6 Cam locking/setting kit, Maxscan GS500 OBDII code reader/EML resetter available.  

Migv6 le Frog Fan

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • Webs End.
  • Posts: 6714
  • Nicole's Papa
    • 3.2 Elite & Welsh Hatch
    • View Profile
Re: Hi all In trouble already.
« Reply #11 on: 02 December 2019, 21:14:20 »

The switch that needs cleaning isn't under the gearstick. Its under the car on the o/s of the gearbox.
Logged
Plastic Welsh hatchbacks are awesome.

YZ250

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Oxford/Bucks border
  • Posts: 2855
    • Black 3.2 Elite Estate
    • View Profile
Re: Hi all In trouble already.
« Reply #12 on: 02 December 2019, 21:22:18 »

So i guess that its a clean on the gear selector stuff under the stick.If the orange light is on does it go into limp mode.Thanks

It's actually under the car, so accessed from underneath.  :y

On the way back all of a sudden all the lights lit up along the gear selector ie 1 2 3 D R it seemed slower to accelerate.

This happened to me on my previous Omega. I was still able to use the gearbox manually to maintain acceleration and speed. I just selected 1st to pull away and shifted to 2nd, 3rd and then drive to maintain normal acceleration. Cleaned the switch and that sorted it to run in auto mode again.  :y
Logged
My fun car is a 2019 Bmw F32 430d M Sport with indicators.
My cruiser is an Audi A6 Avant Black Edition with indicators.

Entwood

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • North Wiltshire
  • Posts: 19140
  • My Old 3.2 V6 Elite (LPG)
    • Audi A6 Allroad 3.0 DTI
    • View Profile
Re: Hi all In trouble already.
« Reply #13 on: 02 December 2019, 21:31:18 »

This is the guide you need to use to clean the selector switch ..

http://www.omegaowners.com/forum/index.php?topic=90673.0

not the easiest thing to get to on a drive/axle stands in the cold and wet ...... :(

so always worth the "cycle through" attempt IMHO .....
Logged
V6 Cam locking/setting kit, Maxscan GS500 OBDII code reader/EML resetter available.  

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #14 on: 02 December 2019, 21:51:15 »

Wicked nice one.Was thinking it might be toast but have worked on a 2.2 before but it was a manual.Ive taken a look at the old guide for stripping it down and i see what you mean now its on the gearbox housing and i supposed it gets mucked up inside on the tracks.Is the orange car spanner light directly related to that fault or is that something else.
Logged

Enceladus

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 415
    • View Profile
Re: Hi all In trouble already.
« Reply #15 on: 02 December 2019, 22:49:30 »

You also need to find out why the spanner light is on. Try the pedal trick and report back the codes.
Logged

polilara

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • Finland
  • Posts: 545
    • 2.6 Y26SE Elegance 2001
    • View Profile
Re: Hi all In trouble already.
« Reply #16 on: 03 December 2019, 07:44:15 »

I had something similar and had to change the whole selector, cleaning did not help as one (or some) of those leading metal sheets inside were totally cut.

https://www.omegaowners.com/forum/index.php?topic=119060.0
Logged

omegod

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • liverpool
  • Posts: 4096
    • 2017 Seat Ateca
    • View Profile
Re: Hi all In trouble already.
« Reply #17 on: 03 December 2019, 14:13:25 »

You also need to find out why the spanner light is on. Try the pedal trick and report back the codes.

Pedal trick doesn't work on the 2.2 IIRC , no idea why  :-\
Logged
Happy to do Omega servicing etc around Merseyside,cruise activation, airbag lights sorted too...

BazaJT

  • Omega Lord
  • *******
  • Offline Offline
  • Gender: Male
  • SLady bitshorpe N.Lincs.
  • Posts: 6766
    • Omega 3 litre Elite
    • View Profile
Re: Hi all In trouble already.
« Reply #18 on: 03 December 2019, 17:50:44 »

Do try and keep up omegod ::) the op has previously had a 2.2 but now has a 2.6 with which he's having the problem :y
Logged

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #19 on: 03 December 2019, 18:11:54 »

Hi everyone ive been out to the car and cycled the gear selector back and through the range 6 or 7 times slowly and between D and N the yellow selector lights flicker for a second or so.I also hooked up a Autel canbus code  reader and read the codes it was showing zero.But i noticed the orange spanner light was not on the dash anymore but i guess i need to take it for a drive and see.
Logged

Andy B

  • Get A Life!!
  • **********
  • Offline Offline
  • Gender: Male
  • Bury Lancs
  • Posts: 36856
    • R320 TDM850 SmartRoadster
    • View Profile
Re: Hi all In trouble already.
« Reply #20 on: 03 December 2019, 18:14:54 »

Hi everyone ive been out to the car and cycled the gear selector back and through the range 6 or 7 times slowly and between D and N the yellow selector lights flicker for a second or so.I also hooked up a Autel canbus code  reader and read the codes it was showing zero.But i noticed the orange spanner light was not on the dash anymore but i guess i need to take it for a drive and see.

I'd be surprised if your code reader will read gearbox codes  :-\
Logged

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #21 on: 03 December 2019, 18:19:57 »

Yep didnt think of that i suppose if it was hooked up to Tech 2 you would see it.
Logged

Webby the Bear

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Northampton
  • Posts: 12450
    • 2000 (W Reg.) 2.5 V6 CD
    • View Profile
Re: Hi all In trouble already.
« Reply #22 on: 03 December 2019, 18:54:24 »

Hi everyone ive been out to the car and cycled the gear selector back and through the range 6 or 7 times slowly and between D and N the yellow selector lights flicker for a second or so.I also hooked up a Autel canbus code  reader and read the codes it was showing zero.But i noticed the orange spanner light was not on the dash anymore but i guess i need to take it for a drive and see.

I'd be surprised if your code reader will read gearbox codes  :-\

Depends which Autel he has. Our Snap-off kit wonít communicate at all with my Omega 🤣 Both my Autels will. I have one that just does engine and the other does engine, transmission, abs and srs 😃👍
Logged
RIP Paul Lovejoy

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #23 on: 03 December 2019, 19:09:05 »

Just taken it out for a quick drive autobox was working as it should no orange light on the dash it must be that gear selector switch on gearbox.It was smooth in D and kickdown worked fine.Still no heat and temp gauge flat zero.
Logged

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #24 on: 03 December 2019, 19:15:01 »

Autel is a AL 301
Logged

Webby the Bear

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Northampton
  • Posts: 12450
    • 2000 (W Reg.) 2.5 V6 CD
    • View Profile
Re: Hi all In trouble already.
« Reply #25 on: 03 December 2019, 19:28:44 »

Looking at that itís just a code reader for engine. No live data function either. Donít think youíll get GB codes from that, only engine  :y
Logged
RIP Paul Lovejoy

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #26 on: 03 December 2019, 19:42:14 »

Yep your right as ive just been out in it again.There was no orange car spanner on dash but Traction control and the orange spanner both came on at the same time permanently.
Logged

gavlar001

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • kent
  • Posts: 12
    • omega 2.6 mv6
    • View Profile
Re: Hi all In trouble already.
« Reply #27 on: 03 December 2019, 19:56:11 »

Have read in another thread of someone having a similar problem and having TC light and Spanner orange car light come up due to that switch.Also if you gently push left or right the fully lit yellow gear indication lights all go out if its in drive.What grease should you use to put back in it when its clean.
Logged
Pages: 1 2 [All]   Go Up
 

Page created in 0.144 seconds with 21 queries.