Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please check the Forum Guidelines at the top of the Newbie section

Pages: [1]   Go Down

Author Topic: A Few Irritating Electrical Problems!  (Read 1160 times)

0 Members and 1 Guest are viewing this topic.

Corsa_Convertible

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Bristol
  • Posts: 2
    • View Profile
A Few Irritating Electrical Problems!
« on: 14 September 2006, 16:38:40 »

I have recently become the proud owner of a 1997 Omega Tourer

These may be connected, as they seem to be on the same fuse (14) Which is intact.

Firstly the Heated rear window will not work. I have replaced the switch.... and had the relay checked. interestingly if you manually close the circuit on the relay, the light on the switch comes on and the window de-mists.

Secondly, The Recirculation control seems dead. No light on the switch when toggled, and I can't hear any motors whiring or change in the air flow from outside air to inside air. I've changed the switch, still no joy

Finally the cigarette lighter (front and rear)  does not work although the bulb in it's rim does. Tested both with bulb and wire, dead as a doornail!

Any suggestion (or recommendation of a good auto electrician in the Bristol Area) would be welcome

Thanks you!
Logged
Drives a Marmite Car (You'll either love it or hate it!)

Hillper

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Aylesbury
  • Posts: 435
  • Werthers. Winter, too hard.  Summer, too soft.
    • View Profile
Re: A Few Irritating Electrical Problems!
« Reply #1 on: 15 September 2006, 23:41:52 »

I will have a look at my circuit diagram tomorrow.
Logged
Mods.  'Hillper boot release'.  Dimming mirror.  Cruise control. Rear parking sensors.  Becker/Rockford Fosgate/Infinity/Alpine audio.

Kev

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Male
  • Glasgow
  • Posts: 1473
  • .:The OmegaProject:.
    • View Profile
Re: A Few Irritating Electrical Problems!
« Reply #2 on: 21 September 2006, 21:28:51 »

Have you actually tried changing the fuse? I've seen this before, caused by bad spade connections. Get a new fuse and pop it in.

Also get the meter onto both sides of the fuse, make sure your power is ok there.

I'd be very surprised if all these faults were a coincidence.  ::)
Logged
OmegaProject.co.uk .:.  Fuelled with passion...
[img name=signat_img_resize]http://i94.photobucket.com/albums/l92/xthreezero/omegaproject/oof-sig.jpg[/IMG]

Hillper

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • Aylesbury
  • Posts: 435
  • Werthers. Winter, too hard.  Summer, too soft.
    • View Profile
Re: A Few Irritating Electrical Problems!
« Reply #3 on: 23 September 2006, 15:46:01 »

Thought I'd replied to this already?

Bit of a coincidence indeed!

Assuming fuses are OK (and we won't know unless he posts again!), the A/C control unit sends the control signal to the relay.  Could be the control unit U/S.

I wonder if the other A/C functions are normal?
Logged
Mods.  'Hillper boot release'.  Dimming mirror.  Cruise control. Rear parking sensors.  Becker/Rockford Fosgate/Infinity/Alpine audio.

Corsa_Convertible

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • Bristol
  • Posts: 2
    • View Profile
Re: A Few Irritating Electrical Problems!
« Reply #4 on: 26 September 2006, 10:04:03 »

Sorry Chaps

On holiday for a week. Meeeega performed admirably, also managed to strip lots on bits and bobs off a scraped Omega for which I was only charged one whole english pound!

Firstly

I have swapped the fuse, I believe fuse 14 has quite a bit on it, including the Radio. Everything works except the above.

Secondly

The A/C (Air Conditioning?) Is okay, quite cold! switch displays little orange light when toggled.

Thanks for your suggestions

CC
Logged
Drives a Marmite Car (You'll either love it or hate it!)
Pages: [1]   Go Up
 

Page created in 0.135 seconds with 21 queries.