Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to OOF

Pages: 1 2 3 4 [All]   Go Down

Author Topic: auto gearbox not powerful when cold  (Read 4799 times)

0 Members and 1 Guest are viewing this topic.

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
auto gearbox not powerful when cold
« on: 05 December 2011, 16:50:13 »

  :-\  mine Speed Bird 2.2l 2001 z22xe when the car is cold the gearbox becomes very week, it can only go in motion in gear 1 or 2, it cannot even go in sports mode. but when I stop for a few secs and turn off the engine then on again then it will drive normally. the mech tried to top up the oil but no help. cud u guys help pliz. Gibby
Logged

RobG

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Bristol
  • Posts: 13824
  • I might have a link, pic or part number for that
    • 16 plate Mokka. Vivaro
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #1 on: 05 December 2011, 16:54:03 »

Suggest checking if any codes are stored. Wouldn`t be surprised if you have an 0340 lurking somewhere (cam sensor)
Logged
All that is necessary for the triumph of evil is that good men do nothing.

UPVC windows/doors/fascias/soffit/gutters supplied/fitted

Debs.

  • Guest
Re: auto gearbox not powerful when cold
« Reply #2 on: 05 December 2011, 17:59:59 »

Did the mechanic check the ATF level the correct way: with the engine running (etc.)?
Logged

PhilRich

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • A bit further North of the Back of Beyond!
  • Posts: 10338
    • Mk 2 Volvo V70
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #3 on: 05 December 2011, 18:39:12 »

Isn't it 'normal' for the Omega to hang on to a low gear from a cold start, mine does? :-\
Logged
If it ain't broke keep fixing it 'til it is!

RobG

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Bristol
  • Posts: 13824
  • I might have a link, pic or part number for that
    • 16 plate Mokka. Vivaro
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #4 on: 05 December 2011, 18:43:37 »

  :-\  mine Speed Bird 2.2l 2001 z22xe when the car is cold the gearbox becomes very week, it can only go in motion in gear 1 or 2, it cannot even go in sports mode. but when I stop for a few secs and turn off the engine then on again then it will drive normally. the mech tried to top up the oil but no help. cud u guys help pliz. Gibby
Assume he means he manually has to select 1 or 2 Phil,
Logged
All that is necessary for the triumph of evil is that good men do nothing.

UPVC windows/doors/fascias/soffit/gutters supplied/fitted

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #5 on: 05 December 2011, 18:59:50 »

  :-\  mine Speed Bird 2.2l 2001 z22xe when the car is cold the gearbox becomes very week, it can only go in motion in gear 1 or 2, it cannot even go in sports mode. but when I stop for a few secs and turn off the engine then on again then it will drive normally. the mech tried to top up the oil but no help. cud u guys help pliz. Gibby
Assume he means he manually has to select 1 or 2 Phil,
not really, I mean driving from D and if I pressS for sport the S comes on the dashboard that does not happen when the gearbox is powerless as described earlier, thax sir
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #6 on: 05 December 2011, 19:07:49 »

Isn't it 'normal' for the Omega to hang on to a low gear from a cold start, mine does? :-\

Sir, I mean when the gbox is in the powerless, It will not sound normal and sport mode can't be engaged. and u cud feel that the gbox is not working normally,mainly in D.
Logged

Andy B

  • Get A Life!!
  • **********
  • Offline Offline
  • Gender: Male
  • Bury Lancs
  • Posts: 35879
    • R320 TDM850 SmartRoadster
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #7 on: 05 December 2011, 19:10:57 »

Isn't it 'normal' for the Omega to hang on to a low gear from a cold start, mine does? :-\

Sir, I mean when the gbox is in the powerless, It will not sound normal and sport mode can't be engaged. and u cud feel that the gbox is not working normally,mainly in D.

You're car feels gutless cos there's a fault of some sort (not always on the gearbox) and the car is setting off in 3rd gear - you'll not be getting top either.
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #8 on: 05 December 2011, 19:12:14 »

Did the mechanic check the ATF level the correct way: with the engine running (etc.)?

I'm not sure, and what is ATF SIR? THX
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #9 on: 05 December 2011, 19:15:09 »

Isn't it 'normal' for the Omega to hang on to a low gear from a cold start, mine does? :-\

Sir, I mean when the gbox is in the powerless, It will not sound normal and sport mode can't be engaged. and u cud feel that the gbox is not working normally,mainly in D.

You're car feels gutless cos there's a fault of some sort (not always on the gearbox) and the car is setting off in 3rd gear - you'll not be getting top either.

HELLO SIR, BUT AT TIMES THERE IS A WUUUUU SOUND OF SORT
Logged

RobG

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Bristol
  • Posts: 13824
  • I might have a link, pic or part number for that
    • 16 plate Mokka. Vivaro
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #10 on: 05 December 2011, 19:17:00 »

Any warning light on dashboard, continuous or intermittent??
Logged
All that is necessary for the triumph of evil is that good men do nothing.

UPVC windows/doors/fascias/soffit/gutters supplied/fitted

Andy B

  • Get A Life!!
  • **********
  • Offline Offline
  • Gender: Male
  • Bury Lancs
  • Posts: 35879
    • R320 TDM850 SmartRoadster
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #11 on: 05 December 2011, 19:25:50 »

Did the mechanic check the ATF level the correct way: with the engine running (etc.)?

I'm not sure, and what is ATF SIR? THX

Automatic Transmission Fluid  :y
Logged

Andy B

  • Get A Life!!
  • **********
  • Offline Offline
  • Gender: Male
  • Bury Lancs
  • Posts: 35879
    • R320 TDM850 SmartRoadster
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #12 on: 05 December 2011, 19:26:30 »

.....
HELLO SIR, BUT AT TIMES THERE IS A WUUUUU SOUND OF SORT

How's it go again .................  ::) ::) ::)  ;)
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #13 on: 05 December 2011, 20:57:02 »

Any warning light on dashboard, continuous or intermittent??

Yes, engine management light is continuous
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #14 on: 05 December 2011, 20:58:58 »

Any warning light on dashboard, continuous or intermittent??

yes, continuous engine management light
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #15 on: 05 December 2011, 21:01:05 »

Suggest checking if any codes are stored. Wouldn`t be surprised if you have an 0340 lurking somewhere (cam sensor)

yes code PO700
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #16 on: 05 December 2011, 21:04:05 »

Im not far away.Are you at home during daylight hours ?
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #17 on: 05 December 2011, 21:24:24 »

Im not far away.Are you at home during daylight hours ?

HELLO SIR,  YES FORM O800HRS
Logged

PhilRich

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • A bit further North of the Back of Beyond!
  • Posts: 10338
    • Mk 2 Volvo V70
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #18 on: 05 December 2011, 21:28:33 »

Nobody's called me Sir (and meant it) since 1982 at which time I was allowed back into Civvy Street & once again became plain 'Oy You!', so Thankyou gibby for your Good Manners, may I take it as read that you are not a Native of this Green & Pleasant Land? ;D ;D ;D  ;)
Logged
If it ain't broke keep fixing it 'til it is!

fiend61

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Male
  • york
  • Posts: 1544
  • each to their own
    • 2.5cdx 3.0mv6 3.2vec c
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #19 on: 05 December 2011, 21:31:17 »

Quote
Green & Pleasant Land

dont forget  wet  cold  miserable etc etc  :D
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #20 on: 05 December 2011, 21:57:18 »

PM incoming. :y
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #21 on: 06 December 2011, 08:02:28 »

PM incoming. :y

I really appreciate that, my cell no. is 07789742290. be blessed :)
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #22 on: 06 December 2011, 15:21:29 »

Im not far away.Are you at home during daylight hours ?

hello sir, are u really coming today?
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #23 on: 06 December 2011, 17:47:58 »

Not today mate.I will give you a call when I can get over. :y
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #24 on: 06 December 2011, 18:19:56 »

Suggest checking if any codes are stored. Wouldn`t be surprised if you have an 0340 lurking somewhere (cam sensor)

yes code PO700

Code P0700 is - MIL request from transmission control (TC) Module, and/or  EOBD error stored by Transmission control  (TC ) module. Anyone able to shed some light on this ?
Im hoping to go and have a look for the OP some time soon if possible. Will take O**** reader and some tools.Hopefully will be able to assist.
« Last Edit: 06 December 2011, 18:21:40 by Albs »
Logged

Debs.

  • Guest
Re: auto gearbox not powerful when cold
« Reply #25 on: 06 December 2011, 18:27:24 »

Suggest checking if any codes are stored. Wouldn`t be surprised if you have an 0340 lurking somewhere (cam sensor)

yes code PO700

Code P0700 is - MIL request from transmission control (TC) Module, and/or  EOBD error stored by Transmission control  (TC ) module. Anyone able to shed some light on this ?
Im hoping to go and have a look for the OP some time soon if possible. Will take O**** reader and some tools.Hopefully will be able to assist.

 8) Well done that man! :y
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #26 on: 06 December 2011, 18:35:26 »

Havent done anything yet. :D ;D
May be a case of the partially sighted leading the visually challenged. ;D
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #27 on: 06 December 2011, 19:53:10 »

Not today mate.I will give you a call when I can get over. :y

thax, I will be waiting.
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #28 on: 06 December 2011, 19:57:49 »

Suggest checking if any codes are stored. Wouldn`t be surprised if you have an 0340 lurking somewhere (cam sensor)

yes code PO700

Code P0700 is - MIL request from transmission control (TC) Module, and/or  EOBD error stored by Transmission control  (TC ) module. Anyone able to shed some light on this ?
Im hoping to go and have a look for the OP some time soon if possible. Will take O**** reader and some tools.Hopefully will be able to assist.

hello sir, thax very much for ur effort to help me, wel done, I really appreciate this.
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #29 on: 07 December 2011, 10:23:08 »

Suggest checking if any codes are stored. Wouldn`t be surprised if you have an 0340 lurking somewhere (cam sensor)

yes code PO700

Code P0700 is - MIL request from transmission control (TC) Module, and/or  EOBD error stored by Transmission control  (TC ) module. Anyone able to shed some light on this ?
Im hoping to go and have a look for the OP some time soon if possible. Will take O**** reader and some tools.Hopefully will be able to assist.

gud morning sir, any news about the code i posted? Thax
Logged

feeutfo

  • Guest
Re: auto gearbox not powerful when cold
« Reply #30 on: 07 December 2011, 10:40:37 »

http://www.obd-codes.com/p0700

Code not specific enough to be of help. Suprises me that the 2.2 power putput causes the auto box problems, and always wonder if there are any engine codes as well, because a faulty crank sensor is known to upset the autobox with that engine.... Or if the automatic transmission fluid was ever changed during the cars life...?

Suspect the ecu has detected slipping or loss of drive. If the fluid is at the correct level with engine running there is little to be done to repair it other than relpace with a known good one.
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #31 on: 07 December 2011, 11:30:14 »

http://www.obd-codes.com/p0700

Code not specific enough to be of help. Suprises me that the 2.2 power putput causes the auto box problems, and always wonder if there are any engine codes as well, because a faulty crank sensor is known to upset the autobox with that engine.... Or if the automatic transmission fluid was ever changed during the cars life...?

Suspect the ecu has detected slipping or loss of drive. If the fluid is at the correct level with engine running there is little to be done to repair it other than relpace with a known good one.

no sure if oil was ever change: I bought this vehicle almost 2 yrs ago. and the probs has been there since, and the funny part of it is that at times it will drive normally and 4 me to find a quick solution, several times whenever it cud go in this condition and I stop and turn the engine off for few seconds, then restart the engine the car would drive normal, and up to now its like that. thax 4 ur effort sir.
Logged

Kevin Wood

  • Global Moderator
  • *****
  • Offline Offline
  • Gender: Male
  • Alton, Hampshire
  • Posts: 34616
    • 3.2 MV6 (LPG), Westfield
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #32 on: 07 December 2011, 12:25:36 »

So far we have an engine ECU code that indicates a request from the gearbox controller to go into limp-home. This indicates that the gearbox ECU has raised an error so the next step is to check the gearbox ECU codes, as I'm sure these will be more specific and may, for example, point to an electrical issue in the wiring to the gearbox.

Meanwhile, a check / change of the auto gearbox fluid would do no harm.

In addition, go through all positions of the auto gearbox selector and make sure that the corresponding lights on the centre console light up cleanly and without flickering between positions. A common problem is that the selector switch gets dodgy and then the auto gearbox ECU gets confused and goes into limp home.

Logged
Tech2 services currently available. See TheBoy's price list: http://theboy.omegaowners.com/

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #33 on: 07 December 2011, 13:55:19 »

Im hoping to go and have a look Saturday Kevin to see if I can help in some way. I believe O**** should be able to retrieve more detailed info from the Trans. ECU ?  :-\
Im thinking - plug in reader,see what it says.depending on info - check ATF level/condition,check electrical connections to gearbox.
Possibility of cam sensor or MAF problems upsetting gearbox ?
Logged

Kevin Wood

  • Global Moderator
  • *****
  • Offline Offline
  • Gender: Male
  • Alton, Hampshire
  • Posts: 34616
    • 3.2 MV6 (LPG), Westfield
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #34 on: 07 December 2011, 17:25:02 »

Sounds like a plan... :y
Logged
Tech2 services currently available. See TheBoy's price list: http://theboy.omegaowners.com/

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #35 on: 10 December 2011, 20:30:41 »

Paid a flying visit to the OP today.Time was short,light was starting to fade and it was cold,but read the codes from engine and box and removed the powersounder as it was doing me ead in.Smashed it up inTescos car park and chucked it in their bin.

Engine codes which came up were as follows -
PO700- EOBD - stored by Transmission control module.
P0136 - o2 sensor high voltage. Not present.
p0170- lean exhaust - present.
p0141 - o2 sensor heater open circuit - present.
P0340 - cam circuit no signal - not present.
p1700 - SVS request via CAN - not present.
p1405 - feedback sensor EGR - not present.
p0036 - o2 sensor heater circuit range/performance bank1 sensor 2.present.
p0304 - cyl4 misfire detected - not present.

Cleared codes, then read them again and had -
p0700 present
p0141 - present
p0304 - present
p1700 - present.

Then read gearbox codes -
p0727 - can recieves error - not present
p1781 unknown DTC - not present
p1740 - unknown DTC - present.

Ran out of time and light at this point.


HELP!!!!!!!!!!  ;D

Guessing a new Lamda sensor may clear some of these codes,but doubt its related to the problem as originally posted. :-\
« Last Edit: 10 December 2011, 20:33:20 by Albs »
Logged

feeutfo

  • Guest
Re: auto gearbox not powerful when cold
« Reply #36 on: 10 December 2011, 21:07:43 »

Paid a flying visit to the OP today.Time was short,light was starting to fade and it was cold,but read the codes from engine and box and removed the powersounder as it was doing me ead in.Smashed it up inTescos car park and chucked it in their bin.

Engine codes which came up were as follows -
PO700- EOBD - stored by Transmission control module.
P0136 - o2 sensor high voltage. Not present.
p0170- lean exhaust - present.
p0141 - o2 sensor heater open circuit - present.
P0340 - cam circuit no signal - not present.p1700 - SVS request via CAN - not present.
p1405 - feedback sensor EGR - not present.
p0036 - o2 sensor heater circuit range/performance bank1 sensor 2.present.
p0304 - cyl4 misfire detected - not present.

Cleared codes, then read them again and had -
p0700 present
p0141 - present
p0304 - present
p1700 - present.

Then read gearbox codes -
p0727 - can recieves error - not present
p1781 unknown DTC - not presentp1740 - unknown DTC - present.

Ran out of time and light at this point.


HELP!!!!!!!!!!  ;D

Guessing a new Lamda sensor may clear some of these codes,but doubt its related to the problem as originally posted. :-\
known to upset autobox on 2.2.
see what others say, but i'd start there i think.
Logged

RobG

  • Omega Queen
  • ********
  • Offline Offline
  • Gender: Male
  • Bristol
  • Posts: 13824
  • I might have a link, pic or part number for that
    • 16 plate Mokka. Vivaro
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #37 on: 10 December 2011, 21:08:37 »

Paid a flying visit to the OP today.Time was short,light was starting to fade and it was cold,but read the codes from engine and box and removed the powersounder as it was doing me ead in.Smashed it up inTescos car park and chucked it in their bin.

Engine codes which came up were as follows -
PO700- EOBD - stored by Transmission control module.
P0136 - o2 sensor high voltage. Not present.
p0170- lean exhaust - present.
p0141 - o2 sensor heater open circuit - present.
P0340 - cam circuit no signal - not present.
p1700 - SVS request via CAN - not present.
p1405 - feedback sensor EGR - not present.
p0036 - o2 sensor heater circuit range/performance bank1 sensor 2.present.
p0304 - cyl4 misfire detected - not present.

Cleared codes, then read them again and had -
p0700 present
p0141 - present
p0304 - present
p1700 - present.

Then read gearbox codes -
p0727 - can recieves error - not present
p1781 unknown DTC - not present
p1740 - unknown DTC - present.

Ran out of time and light at this point.


HELP!!!!!!!!!!  ;D

Guessing a new Lamda sensor may clear some of these codes,but doubt its related to the problem as originally posted. :-\
Although it`s showing as not present, cam sensor will throw that code
Logged
All that is necessary for the triumph of evil is that good men do nothing.

UPVC windows/doors/fascias/soffit/gutters supplied/fitted

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #38 on: 10 December 2011, 21:33:58 »

Paid a flying visit to the OP today.Time was short,light was starting to fade and it was cold,but read the codes from engine and box and removed the powersounder as it was doing me ead in.Smashed it up inTescos car park and chucked it in their bin.

Engine codes which came up were as follows -
PO700- EOBD - stored by Transmission control module.
P0136 - o2 sensor high voltage. Not present.
p0170- lean exhaust - present.
p0141 - o2 sensor heater open circuit - present.
P0340 - cam circuit no signal - not present.
p1700 - SVS request via CAN - not present.
p1405 - feedback sensor EGR - not present.
p0036 - o2 sensor heater circuit range/performance bank1 sensor 2.present.
p0304 - cyl4 misfire detected - not present.

Cleared codes, then read them again and had -
p0700 present
p0141 - present
p0304 - present
p1700 - present.

Then read gearbox codes -
p0727 - can recieves error - not present
p1781 unknown DTC - not present
p1740 - unknown DTC - present.

Ran out of time and light at this point.


HELP!!!!!!!!!!  ;D

Guessing a new Lamda sensor may clear some of these codes,but doubt its related to the problem as originally posted. :-\

  :) I've seen good and helpful people in life but I was really surprise the way ALBS HELPED ME. HE SPENT HIS GAS THUS MONEY, TIME, THUS ALSO MONEY, HIS EQUIPMENT ALL COST MONEY, WHAT A SACRIFICE FOR SOMEONE WHO HE JUST MET ON THE FORUM. MR ALBS IS INDEED A GUD MAN, ONE IN A 1000, I DON'T KNOW HOW TO NREPAY HIM. MAY THE LORD BLESS YOU SIR. GIBBY
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #39 on: 10 December 2011, 21:41:10 »

Not a problem Gibby.Happy to try to help.Thats what the forum is for. :y
The part which you mentioned you had purchased sounds like a cam sensor to me. Might be worth changing that to see what improvement it makes.As you know I was short of time today (between night shifts and wifey - whom isnt very well at the moment - was in tescos shopping) but I will try to make some time as soon as possible to spend some more time trying to help get it sorted.
Hopefully that will be within the next week. :y

Meanwhile - any more suggestions from thos who are more knowledgeable than me are more than welcome.
Logged

jonnycool

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • Merthyr Tydfil, S. Wales
  • Posts: 3565
  • We shag 'em, you eat 'em
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #40 on: 10 December 2011, 21:45:37 »

I can't help in any way, but Albs - great service mate - wish I had the means to be able to do it myself. Well done  :y :y :y

Logged
If at first you don't succeed, skydiving probably isn't for you

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #41 on: 10 December 2011, 22:16:28 »

Not a problem Gibby.Happy to try to help.Thats what the forum is for. :y
The part which you mentioned you had purchased sounds like a cam sensor to me. Might be worth changing that to see what improvement it makes.As you know I was short of time today (between night shifts and wifey - whom isnt very well at the moment - was in tescos shopping) but I will try to make some time as soon as possible to spend some more time trying to help get it sorted.
Hopefully that will be within the next week. :y

Meanwhile - any more suggestions from thos who are more knowledgeable than me are more than welcome.
I really appreciate that sir, God bless u.
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #42 on: 11 December 2011, 17:27:42 »

Im hoping to go and have a look Saturday Kevin to see if I can help in some way. I believe O**** should be able to retrieve more detailed info from the Trans. ECU ?  :-\
Im thinking - plug in reader,see what it says.depending on info - check ATF level/condition,check electrical connections to gearbox.
Possibility of cam sensor or MAF problems upsetting gearbox ?

Hello sir, hope ur ok. today as I was driving to chelmsford to attend church, the SPEED BIRD's engine just went off without any warning. tried to restart but just cranking. rang the recovery, he came tried to scan it but the two scanners were not compartible to omega, I new they cud not becoz they were the ones I saw on amazon going at 15 or so. he just took it home and said find a garage which can scan it. I checked the timing belt but it was in its place. thus what happened tuday, thax gibby.
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #43 on: 11 December 2011, 17:55:02 »

Hard to tell why it would suddenly stop and refuse to restart. :-\ Hopefully some others will be able to offer opinions on possible causes. I will come back and have a look/ read the codes again/help if possible as soon as I possibly can. At the moment,the first possible day would be Wednesday.although that is dependant on Christmas shopping plans etc. - havent started yet. :y
Logged

ngrainqey

  • Omega Baron
  • ******
  • Offline Offline
  • Gender: Male
  • rotherham
  • Posts: 2193
    • BMW E92, 2.6 CD F/L Est.
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #44 on: 11 December 2011, 20:03:39 »

p1740 - i think that relates to the torque convertor or the control of it for lockup if that helps....
i didnt bother reading the previous posts again but was the fluid changed and the correct level?
i've emptied some fluid out of my autobox the other day and when properly hot and run in all gears properly (4th in perticular) i sometimes get a "check - low fluid level" on the mid so im topping up or completly changing the gearbox fluid this next week to see if it stops it going into limp mode - it now only happens when cold and either it kicks down or when you load it up too much like hard acceleration

HTH
alex
Logged
V8!!!!

Kevin Wood

  • Global Moderator
  • *****
  • Offline Offline
  • Gender: Male
  • Alton, Hampshire
  • Posts: 34616
    • 3.2 MV6 (LPG), Westfield
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #45 on: 12 December 2011, 09:47:49 »

If the P0340 came back after clearing the codes then I'd change the cam sensor. Not sure what would have caused it to cut out completely, though. That might be a new problem.

I'd also check wiring to the Lambda sensor. It's complaining about the heater circuit. I'm wondering if the wiring is damaged, has shorted out and taken out the engine management fuse, for example. (hence a code reader won't talk to the ECU as it has no power)
Logged
Tech2 services currently available. See TheBoy's price list: http://theboy.omegaowners.com/

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #46 on: 12 December 2011, 12:56:55 »

Allsounds plausible Kevin.Im hoping to get back over there this week to have another look,so that gives me a direction to go in. :y

« Last Edit: 12 December 2011, 13:00:02 by Albs »
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #47 on: 12 December 2011, 21:20:19 »

Allsounds plausible Kevin.Im hoping to get back over there this week to have another look,so that gives me a direction to go in. :y
hello sir, how is the Chrismas shopping going on? I want just to let u know that I removed the timing cover to check the timing belt if it was ok, and its fine: I turned the engine no any probs, all fine. thax be blessed :)
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #48 on: 12 December 2011, 21:36:36 »

Still at work so havent started Christmas shopping yet. ;D Did the engine actually start ok ?
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #49 on: 13 December 2011, 16:38:49 »

Still at work so havent started Christmas shopping yet. ;D Did the engine actually start ok ?

the battery went flat so I will put it on charge to night, thax
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #50 on: 14 December 2011, 17:33:49 »

Still at work so havent started Christmas shopping yet. ;D Did the engine actually start ok ?

Hello sir, hope ur ok. today I tried to start the car but the battery was powerless: so I tried to jump start and the car started without probs. I left the engine running for almost 20 mins it was running fine but when I swithed it off and try to restart, the battery was still powerless. as it is now the car can start.
Logged

albitz

  • Guest
Re: auto gearbox not powerful when cold
« Reply #51 on: 14 December 2011, 18:07:19 »

I did say it needs a new battery. ;) A visit today wasnt possible. Maybe Friday or Saturday ?? Im seeing what happens on a day to day basis at the moment,and trying to find a couple of hours spare when possible.I will give you a ring when I can say for definite. :)
Logged

gibby

  • Junior Member
  • **
  • Offline Offline
  • Gender: Male
  • braintree
  • Posts: 145
    • View Profile
Re: auto gearbox not powerful when cold
« Reply #52 on: 14 December 2011, 22:48:49 »

I think ur right but how cud a battery working perfectly loose power suddenly? do u think its the battery causes the stall? :-\
Logged
Pages: 1 2 3 4 [All]   Go Up
 

Page created in 0.225 seconds with 21 queries.