Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - ChrisPee

Pages: [1] 2 3 4 5
1
Omega General Help / Re: Erratic 2.2
« on: 22 February 2023, 10:38:00 »
Thanks Doc.

2
Omega General Help / Re: Erratic 2.2
« on: 21 February 2023, 19:37:46 »
Yes Doc, and cleared the tiny 1.5mm hole. It was very gummed and black. Where is the TPS on an Omega, because as of now I'm baffled.

3
Omega General Help / Re: Erratic 2.2
« on: 21 February 2023, 18:32:51 »
Update, I have had a diagnostic on the car Monday and there were several fault codes - misfire cylinder 1 misfire cylinder 3, alarm, etc etc. I had already replaced plugs, rocker cover gasket, coil pack, fuel filter, fuel pump, cleaned crank breather pipe and throttle body. All fault cleared (and EM light and ABS light. Car then ran great. Started car today (instantly) then began running rough again - fault codes remaining are;

PO170-2 Lean Exhaust Not Present
P1555-0 Throttle Position Sensor (TPS) - load signal not plausible with engine load.

Can someone tell me where the TPS is please?

4
Omega General Help / Re: Erratic 2.2
« on: 25 January 2023, 10:26:08 »
I have a new relay, pump and filter. As far as I know this car hasn't been serviced for at least 5 years - hence the fuel, air, oil filter, oil and plug pre-purchase anyway.

5
Omega General Help / Re: Erratic 2.2
« on: 24 January 2023, 15:42:26 »
Hello all, I have an update on the silver car. My mate is having a look at it today and after cleaning the filthy throttle body and finding no difference in the running, but, using a small bottle of petrol he was ably to keep the car running fine. He said he found that the "Schrader" valve was not re-pressurising, so does it look like fuel filter or fuel pump to any of you chaps?
I'm stuck at home with a herniated disc, and my mate Paul is being kind enough to have a play for me.

6
Omega General Help / Re: Erratic 2.2
« on: 16 January 2023, 11:33:48 »
Apologies to all helpers if I'm frustrating everyone, I know it's not an excuse, but I'm only used to 60s 70s cars, when it comes to faults it's usually an easy fix with points caps, carbs etc. I'm not trying to cut any corners, I just thought I'd be prepared with parts before I started. I have been using the black car almost daily for over a year and I'm always one for keeping on top of servicing and quality oil changes every 4 or 5k. I've only been an Omega owner for less that 2 years and I've rarely had any issues. I'm waiting on a quote for the head gasket, I dipped the oil several times and it's definitely emulsified. Thanks again all  :y

7
Omega General Help / Re: Erratic 2.2
« on: 15 January 2023, 15:32:01 »
Well, all bad news so far. On the silver car with the erratic revving, the crank breather was blocked so badly I had to chisel the carbon out. I tried a new fuel pump relay just out of interest - no different. I have a new fuel pump to try next.

Ban news on the black car losing water and pressurising - water in the oil now at dipstick, it was fine when I checked before Christmas.

Not sure where to go with these two now, they're both MOTd and the black one is in very nice condition.

8
Omega General Help / Re: Erratic 2.2
« on: 12 January 2023, 14:03:28 »
Thank you Dr G, I've replaced one small breather on the left of the rocker cover - i found it was collapsed and turned to liquorice! I'm doing the rocker cover gaskets on both cars Saturday, so I'll do all the breather pipes too 😉

I've bough a new fuel relay, fuel pump and a lucas coil pack in case any of those are faulty on one of the cars.

9
Omega General Help / Re: Erratic 2.2
« on: 10 January 2023, 10:23:37 »
I drained all the oil out first  ;)
I'm going to check all breather pipes and fit a new rubber gasket seal Saturday. I haven't really driven them far yet.

10
Omega General Help / Re: Erratic 2.2
« on: 09 January 2023, 20:14:17 »
Hi Nick, I'm in Higham nearish to Dartford. I'm happy to pay someone for their time, I really just want a more knowledgeable opinion. I changed the plugs in both cars (fitted factory GM ones) I have one rocker cover gasket. They were both under a few mm of oil too. Yesterday I took the black car out, it drove fine to the petrol station (10 miles away) then after a short stop it began missing and cutting out completely. I restarted it several times then had to abandon it for the day. When I returned expecting it to be the same, it started first time and drove the 10+ miles home without a single stutter.

11
Omega General Help / Re: Erratic 2.2
« on: 09 January 2023, 17:19:37 »
I don't suppose there are any members in north Kent that would be willing to come and have a look at my two 2.2s are there? I'm losing the will to live with them but really don't want to give up on them. Thanks - Chris 😘

12
Omega General Help / Re: Erratic 2.2
« on: 02 January 2023, 15:37:00 »
👍😉👍

13
Omega General Help / Re: Erratic 2.2
« on: 01 January 2023, 18:10:20 »
One other thing, I dont think I'm allowed to post in the for sale / wanted section, but some kind person had smashed the body of the passenger side wing mirror on the silver car. If by any chance someone has one for sale I would be very grateful, it's actually only the coloured part that is broken. Hope this is okay to post?

14
Omega General Help / Re: Erratic 2.2
« on: 01 January 2023, 18:02:04 »
Dr G, your wisdom is my gain master, the head gasket issue was worrying me. I think I'll give them both a really good going over. The silver car was my dads who passed away in 2014 and the black car was my mums who I lost in 2020. I couldn't bring myself to part with either, and although I know they're not exactly valuable, but I'm a big Vauxhall fan - having Victors, VX 4/90s and a Carlton as well.

15
Omega General Help / Re: Erratic 2.2
« on: 01 January 2023, 17:13:57 »
Sorry for the late reply, been at work every day up till yesterday.
I may have confused things here:
The car that is pressurising has oil in the plug channels - I blew them out and fitted new GM plugs. This car has had EM light on for about a year, but the water-loss issue started a few months ago. The 2nd car with the erratic revving also has plugs under oil, it hasn't been used for a year and only started once a month or so. Waiting on new plugs and I have a 2nd rocker cover gasket for this one too. What is a HBV? ☺

Pages: [1] 2 3 4 5

Page created in 0.016 seconds with 15 queries.