Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: [1]   Go Down

Author Topic: z22xe running problems  (Read 551 times)

0 Members and 1 Guest are viewing this topic.

jimbo1977

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • lincolnj
  • Posts: 1
    • omega 2.2 manual
    • View Profile
z22xe running problems
« on: 25 August 2022, 19:54:23 »

hi my 2.2 cdx Z22XE has been chilling in the garage through the very hot weather , took it to garage to sort out the slight blowing from the cat-manifold joint . nice and easy however , on checking the oil i found that it had gone milky so did oil and filter change straight away , did the gasket on the exhaust joint finding it didnt make any difference when done as .015 feeler guages still fit through the gap and i didnt have any type of paste so will need to redo . on driving back to bed , is running like theres oil in the plug wells ( they are bone dry been checking regularly ) and there also seems to be a sloshing sound !!! the only other thing i did that day was connected the after cat sensor as i noticed that was unplugged .. im leaning towards doing the head gasket ( which i want to do anyway at some point so i know its good ) as it seems to have been drinking coolant as well . i know it could be running like a sack because of false pressure readings at manifold due to leak ... ive also got new cam sensor and coolant valve ready to go on as i thought loss of coolant was the valve at the back . i will redo the exhaust with paste ! and switch out the cam sensor and water switch ( is it hbv valve or something ) . has anybody got any other ideas as what the issues could be ? im 60% sure its a head gasket job even tho only on 67000 miles it has been used for towing .

iyl do the minor possibles first then if need be crack on with the head gasket .
Logged

dave the builder

  • Omega Lord
  • *****
  • Online Online
  • Gender: Male
  • Derbyshire
  • Posts: 6992
    • omega b2 2.6 cdxi
    • View Profile
Re: z22xe running problems
« Reply #1 on: 25 August 2022, 21:37:33 »

Sounds like the head gasket ,pressure test the cooling system and find out  .
if it is the head gasket then the other jobs can be done while it's apart for the head gasket  :y
otherwise you are just wasting time, oil, coolant and sealant  :D
Logged

jimbo1977

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • lincolnj
  • Posts: 1
    • omega 2.2 manual
    • View Profile
Re: z22xe running problems
« Reply #2 on: 28 August 2022, 03:01:41 »

hi dave , thanks for the reply  :) unsure if i can do pressure test as header tank has got a small split in near the cap , again making me think its HG with hot gasses  entering the cooling system and its been doing the bubbling up at times when ive taken the cap off , possibly damaged the tank ? like i said i want to do the HG anyway so i know its good , kits already here for that ive just got to order new cam belt n water pump hopefully will get it finished just in time for MOT in october . im wondering if its had that K seal stuff put in at sometime  ;D guess i will find out soon

thanks .... richard
Logged

Doctor Gollum

  • Get A Life!!
  • *****
  • Online Online
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 25426
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: z22xe running problems
« Reply #3 on: 28 August 2022, 10:49:29 »

The tanks fail for the fun of it. Which won't be helping the coolant temp management.

Without being able to pressurise, the coolant will boil off.
Logged
Onanists always think outside the box.

dave the builder

  • Omega Lord
  • *****
  • Online Online
  • Gender: Male
  • Derbyshire
  • Posts: 6992
    • omega b2 2.6 cdxi
    • View Profile
Re: z22xe running problems
« Reply #4 on: 28 August 2022, 11:24:23 »

Replace the header tank ,then do a pressure test
or even JB weld it to test the system while you source another tank
procrastination  - working tomorrow for a better today  ;D
Logged

jimbo1977

  • Newbie
  • *
  • Offline Offline
  • Gender: Male
  • lincolnj
  • Posts: 1
    • omega 2.2 manual
    • View Profile
Re: z22xe running problems
« Reply #5 on: 08 October 2022, 06:07:24 »

hi just a update , time and weather were against me so i let my local garage do the HG , after having a final look myself after a run and taking the plugs out no 3 had water in , pretty conclusive ! also had water pump / CB and gubbings replaced . the only slight running issue now in a hairline crack on the top of the exhaust manifold . MOT due soon needs new arms , d & p all round and few other smalls , also been advised to scrub and repaint the sills . thanks for help and advice guys will post again soon :)
Logged
Pages: [1]   Go Up
 

Page created in 0.03 seconds with 17 queries.