Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: 1 2 [3] 4 5  All   Go Down

Author Topic: Radio on, no sound  (Read 2014 times)

0 Members and 1 Guest are viewing this topic.

dave the builder

  • Omega Lord
  • *****
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 7625
    • omega b2 2.6 cdxi
    • View Profile
Re: Radio on, no sound
« Reply #30 on: 06 November 2023, 22:40:55 »

You could do it cheaper
facia 10 + 2DIN Bluetooth 7 Inch Touch Screen 23
add a loom adaptor and rear view camera and you can use screen mirroring from your phone

I have similar fitted to my 53 plate CDX
still working after 5 years of daily use ,for all the naysayers  >:D


Seems ridiculously cheap!!  :o :o

Was it easy to fit (for a bonehead like me)?
I paid a lot more when I got mine ,but that was 5+ years ago, tech goes down in price .
radio is simple to fit with a loom adaptor
rear view camera needs a connection to the rear cluster (so when reverse is selected the camera comes on ) but that is true of most cameras .
I used a wired connection to the rear camera , not wireless, so needed to run a wire from the head unit to the camera ,which i mounted under the rear reg plate (black dot under reg in pic) 


not hard to do
Logged

Migalot

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 676
    • Omega 2.6 2002
    • View Profile
Re: Radio on, no sound
« Reply #31 on: 06 November 2023, 22:47:46 »

Thanks Dave. I'll certainly give it some thought.  :y :y

The only downside is buying cheap Chinese, when I would prefer to buy nearer to home  ;) (plus, as Albs points out, DAB radio is probably desirable).

PS. Your car looks great!  :y
« Last Edit: 06 November 2023, 22:49:36 by Migalot »
Logged

dave the builder

  • Omega Lord
  • *****
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 7625
    • omega b2 2.6 cdxi
    • View Profile
Re: Radio on, no sound
« Reply #32 on: 06 November 2023, 22:55:11 »



Out of interest what did you fit and did it work with the steering wheel controls.
as per my previous post  ::)

You could do it cheaper
facia 10 + 2DIN Bluetooth 7 Inch Touch Screen 23
add a loom adaptor and rear view camera and you can use screen mirroring from your phone

I have similar fitted to my 53 plate CDX
still working after 5 years of daily use ,for all the naysayers  >:D


you can set them up to work with the steering controls with the correct loom adaptor ,
I didn't bother ,nor do i bother with the included remote control  ::)

Logged

dave the builder

  • Omega Lord
  • *****
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 7625
    • omega b2 2.6 cdxi
    • View Profile
Re: Radio on, no sound
« Reply #33 on: 06 November 2023, 22:59:19 »

Thanks Dave. I'll certainly give it some thought.  :y :y

The only downside is buying cheap Chinese, when I would prefer to buy nearer to home  ;) (plus, as Albs points out, DAB radio is probably desirable).

PS. Your car looks great!  :y

have a good shop around  ;)
most after market options will require the 10 facia surround  ;)
I can't seem to find a pic of the head unit in my Omega  :(
Logged

Doctor Gollum

  • Get A Life!!
  • *****
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 27451
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Logged
Onanists always think outside the box.

Migalot

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 676
    • Omega 2.6 2002
    • View Profile
Logged

Migalot

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 676
    • Omega 2.6 2002
    • View Profile
Re: Radio on, no sound
« Reply #36 on: 29 November 2023, 15:57:56 »

FFS >:( >:( >:( >:( >:(

Had a new Kenwood unit professionally fitted and it worked a treat. Android auto play, hands-free, the works.

I say "worked", because today whilst driving, the sound went. No radio, no YT streaming music (thought counter was showing it as playing).

It MUST be something to do with the car, but what???

Totally fed-up now. 
Logged

cam.in.head

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Male
  • West yorkshire
  • Posts: 1214
    • omega cdx 2.6 auto
    • View Profile
Re: Radio on, no sound
« Reply #37 on: 29 November 2023, 17:11:12 »

take it back to them and get them to check their work.
but
cannot see any chance all 4 speakers would fail so are you 100% sure there is nothing in the speaker line that cuts them such as a phone system or something ? ? as i mentioned before ? anything that would mute all 4 speakers plus the tweeters ?   
Logged

Migalot

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 676
    • Omega 2.6 2002
    • View Profile
Re: Radio on, no sound
« Reply #38 on: 29 November 2023, 17:27:04 »

take it back to them and get them to check their work.
but
cannot see any chance all 4 speakers would fail so are you 100% sure there is nothing in the speaker line that cuts them such as a phone system or something ? ? as i mentioned before ? anything that would mute all 4 speakers plus the tweeters ?

No, nothing.

I don't have a Bose system, but does the OEM unit have a regular amp somewhere?
Logged

Doctor Gollum

  • Get A Life!!
  • *****
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 27451
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: Radio on, no sound
« Reply #39 on: 29 November 2023, 17:37:26 »

Nope unless it's suffered previous buggery
Logged
Onanists always think outside the box.

dave the builder

  • Omega Lord
  • *****
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 7625
    • omega b2 2.6 cdxi
    • View Profile
Re: Radio on, no sound
« Reply #40 on: 29 November 2023, 17:47:08 »

 It is possible that one of the door shut looms has broken wires ,if these get shorted intermittently  :o it can cause all sorts of issues
more of a problem on true canbus wiring ,but possible on an Omega too  :-\

not saying that's the case here ,just a possibility  ;) 
Logged

Migalot

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 676
    • Omega 2.6 2002
    • View Profile
Re: Radio on, no sound
« Reply #41 on: 29 November 2023, 17:58:00 »

It is possible that one of the door shut looms has broken wires ,if these get shorted intermittently  :o it can cause all sorts of issues
more of a problem on true canbus wiring ,but possible on an Omega too  :-\

not saying that's the case here ,just a possibility  ;)

How can I check, short of taking the doors off, that is?
Logged

dave the builder

  • Omega Lord
  • *****
  • Offline Offline
  • Gender: Male
  • Derbyshire
  • Posts: 7625
    • omega b2 2.6 cdxi
    • View Profile
Re: Radio on, no sound
« Reply #42 on: 29 November 2023, 18:31:25 »

It is possible that one of the door shut looms has broken wires ,if these get shorted intermittently  :o it can cause all sorts of issues
more of a problem on true canbus wiring ,but possible on an Omega too  :-\

not saying that's the case here ,just a possibility  ;)

How can I check, short of taking the doors off, that is?
test the speaker wiring at the radio with a muti- meter for resistance for anything obvious plus see if it alters when a "helper" opens and shuts the doors ,
being an intermittent fault , not easy  :(
but ,,,
a speaker loom short would stop the omega's wax disk player & radio grams amp  :P
or even a new head units amp

as I said "not saying that's the case here ,just a possibility"

Logged

cam.in.head

  • Omega Knight
  • *****
  • Offline Offline
  • Gender: Male
  • West yorkshire
  • Posts: 1214
    • omega cdx 2.6 auto
    • View Profile
Re: Radio on, no sound
« Reply #43 on: 30 November 2023, 11:08:25 »

yes i would say thats the next step . if its inteemittent its harder but if it now has no sound permanently then remove the radio and get a multimeter on the speaker connector. due to the wire lengths and front tweeters coupled to the front door speajers you may not get a perfect identical resistance from all 4 circuits but an open or shortshould be obvious. (or ask installer to check ? )
Logged

Doctor Gollum

  • Get A Life!!
  • *****
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 27451
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: Radio on, no sound
« Reply #44 on: 30 November 2023, 11:34:42 »

You haven't inadvertently pressed mute? It's probably a stupid question but new to you gadgets might have quirks and features that take some getting used to ;)
Logged
Onanists always think outside the box.
Pages: 1 2 [3] 4 5  All   Go Up
 

Page created in 0.013 seconds with 18 queries.