Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: [1]   Go Down

Author Topic: Random locking issue  (Read 181 times)

0 Members and 1 Guest are viewing this topic.

iansoutham

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • SE London
  • Posts: 448
    • Omega 2.0 m/f/l est CDX
    • View Profile
Random locking issue
« on: 13 March 2021, 11:08:44 »

Have noticed recently that when locking the car with the remote, not always do all the door lock. There will be a random one or 2 that stays unlocked.

Example would be working fine, then lock the car and all but the drivers rear locks. Next time, might be both drivers doors. Then might work for a few times and then passenger rear door (example).

If you press the lock button again to deadlock, they lock. If you unlock and try again, they lock fine. Always unlock fine.

You can tell if one has not locked by the sound. When not working properly, you get like a slurping sound, but a resounding clunk when they all work if that makes sense.

Other thing is that the alarm horn was removed years ago but have put another horn on and still makes no noise, just flashes lights. Even tried a proper car horn with no sound, related?

Power Sounder was binned in 2015 so that gone.

Part of me thinks CDL unit? Have not done a Tech 2 yet but suspect will not show anything.

Car has been used almost daily during last year as well so not due to being left parked up either.

Thoughts?
Logged

Doctor Gollum

  • Over Active Thyroid
  • *********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 20991
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: Random locking issue
« Reply #1 on: 13 March 2021, 11:27:36 »

Can the Omega be programmed to only unlock the drivers door? A side effect of pressing both buttons at the same time on most cars. Unlikely given other symptoms.

Locks won't work of the door is/or the car thinks it is open. So the contact switches could be the issue.

Just because you drive it every day doesn't preclude damp from being the cause, especially if the aircon doesn't work as, iirc, your commute doesn't actually warm the car up ;)

In order,

Contact switches
Failing CL motors (all 4)
Wiring

Logged
Onanists always think outside the box.

iansoutham

  • Intermediate Member
  • ***
  • Offline Offline
  • Gender: Male
  • SE London
  • Posts: 448
    • Omega 2.0 m/f/l est CDX
    • View Profile
Re: Random locking issue
« Reply #2 on: 13 March 2021, 11:53:40 »

Car does not mist up anymore so hoping/guessing leaks all gone.

Am thinking microswitches and possibly osr door lock/motor as that seems the most common.

Just hoping for some better ideas before I go ripping it all to pieces in April
Logged
Pages: [1]   Go Up
 

Page created in 0.089 seconds with 21 queries.