Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Search the maintenance guides for answers to 99.999% of Omega questions

Pages: 1 [2]  All   Go Down

Author Topic: High CO emissions at fast idle again on X20XEV  (Read 366 times)

0 Members and 2 Guests are viewing this topic.

Doctor Gollum

  • Over Active Thyroid
  • *********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 20991
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: High CO emissions at fast idle again on X20XEV
« Reply #15 on: 07 April 2021, 11:36:01 »

 Could have been built for the Irish market and then simply rebadged as ordered. The build data should specify all the info.

For example, I know my Merc was built for the UK but supplied to the original customer unregistered just from the data sheet.
Logged
Onanists always think outside the box.

Enceladus

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • London
  • Posts: 722
    • View Profile
Re: High CO emissions at fast idle again on X20XEV
« Reply #16 on: 07 April 2021, 13:54:24 »

Regardless of the intended market and branding all Omega B and B2 were built by Opel Automobile GmbH in Rüsselsheim am Main. So don't they all say Opel or Adam Opel AG?
Logged

Doctor Gollum

  • Over Active Thyroid
  • *********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 20991
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: High CO emissions at fast idle again on X20XEV
« Reply #17 on: 07 April 2021, 14:08:50 »

I'll check the plates of mine...
Logged
Onanists always think outside the box.

Doctor Gollum

  • Over Active Thyroid
  • *********
  • Offline Offline
  • Gender: Male
  • In a colds and darks puddleses
  • Posts: 20991
  • If you can't eat them, join them...
    • Feetses.
    • View Profile
Re: High CO emissions at fast idle again on X20XEV
« Reply #18 on: 07 April 2021, 15:39:23 »

I'll check the plates of mine...
Both Opel. And no country of manufacture, although iirc, the production site is a letter in the chassis number...

Mercedes give the official company name and "Made in..." Daimler Chrysler and "Germany" in the case of the Barge.

It's interesting that different manufacturers approach the same thing so differently.
Logged
Onanists always think outside the box.

addy

  • Senior Member
  • ****
  • Offline Offline
  • Gender: Male
  • County Durham.  UK
  • Posts: 517
    • 2002 2.6 CD Saloon
    • View Profile
Re: High CO emissions at fast idle again on X20XEV
« Reply #19 on: Today at 21:48:22 »

Well the laptop decided to shutdown twice, but got some data. It was taken from car started, with no throttle. It was 0 degrees outside and the car was white with frost. The new coolant temp sensor seems to be working, also think the new Genuine IAT, new ICV and genuine NKG O2 sensor, correct for the cars year are seeming to be working? Or can anyone see anything amiss?

Thanks in advance for any help.

Data taken today.
First part from cold, before laptop shutdown
https://drive.google.com/file/d/1cSc5XuPcl_zaCpNUnFmZRAh1cIuRW23N/view?usp=sharing

2nd part once sorted laptop
https://drive.google.com/file/d/1wDtJbJ-5tZJBNp0spKdNNby72Kjl-NIA/view?usp=sharing
Logged
Drives 1995 2.0ltr CD Estate.  2002 2.6 CD saloon
Pages: 1 [2]  All   Go Up
 

Page created in 0.066 seconds with 21 queries.