Omega Owners Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Please play nicely.  No one wants to listen/read a keyboard warriors rants....

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - spursyid

Pages: [1]
1
Omega Electrical and Audio Help / alarm problems
« on: 19 November 2008, 21:07:00 »
Hi ive got a 1999 3.0 elite,The other day all 3 nearside indercaters stayed on permantly,the only way i could get them off was to remove hazzard warning fuse,when fuse put back in all indercators were working,since then when car is locked only nearside indercaters flash and the battery drains if left for 24 hours,any ideas where to start please.

2
Omega General Help / whats it worth?
« on: 20 July 2009, 22:13:26 »
Have got a s reg 3.0 elite with everything including sat nav and leather with 126,000 on it,where is the best place te advertise and how much is it worth?want a omega estate

3
Same happened to me 2 weeks ago,As long as you didnt drive for long you should be fine,Mine as i was told on this site was the aux belt the spring loaded tensioner had gone(bearing siezed)just check all pullys they should all turn apart from the crank,Easy job as long as you have a diagram to help you with the long aux belt. :-*

4
Omega General Help / Re: aux belt
« on: 06 May 2009, 23:01:53 »
All sorted,the tensioner had siezed so relaced the whole unit rather then just the bearing and a new aux belt,Car now running like a dream and no long term damage,Thank you foyr all your help and comments  :y

5
Omega General Help / Re: aux belt
« on: 04 May 2009, 22:38:38 »
drove it about 8 miles,poped bonnet up as soon as i stoped no funny noises no steam or apparant overheating,fan ran on as normal for about 5 mins,car will run if started :(

6
Omega General Help / Re: aux belt
« on: 04 May 2009, 22:18:54 »
Thank you will get onto that in the morning,just hope i`ve not cooked anything
 :)

7
Omega General Help / aux belt
« on: 04 May 2009, 21:55:17 »
I have a 1999 vauxhall omega 3.0 elite and yesterday in the middle of no where with my young kids in the car the power steering went seconds later the red light and temp gauge light went on also the battery light came on,i got back to where i was staying,the engine did not overheat no steam etc the fan ran as normal,I`m guessing the aux belt runs the power steering alternater and water pump.The belt had shredded,whats the next step fit a new belt and check pulleys or will i have done more damage Help please
Hugh :(

8
Omega General Help / Re: xennon headlight bulbs
« on: 05 January 2009, 14:53:26 »
Thank you,will try them much better then 90 for the single bulb i was quoted. ;D

9
Omega General Help / xennon headlight bulbs
« on: 05 January 2009, 12:42:22 »
Can anyone reccomend a good place to buy replacment bulbs,one of mine went last night and cant belive the cost of a new bulb at my local motor factors.

Many Thanks

Hugh :-[

10
Newbie Welcome Area / n
« on: 19 November 2008, 21:13:46 »
Hi new to forums so dont realy now what i am doing,own a 1999 3.0 elite and love it,going to service it soon any tips and which make of plugs do these engines run best on,any advise most welcome,cheers :D

Pages: [1]

Page created in 0.133 seconds with 21 queries.